0

Here is the content of my config file /etc/init.d/vsftpd :

listen=YES
local_enable=YES
local_root=/
write_enable=YES
dirmessage_enable=YES
use_localtime=YES
xferlog_enable=YES
rsa_cert_file=/etc/ssl/private/vsftpd.pem

And here is what I see...

As you can see, I don't see much, and I believe I should. Any suggestion is most welcome.

  • 2
    With an anonymous login I see an empty directory, so your FTP server works, but you probably need to specify an [ anon_root](vsftpd.beasts.org/vsftpd_conf.html) directory to have the right contents appear (and setting it to / is not the best) – HBruijn Sep 9 '15 at 18:44
  • I understood. Based on this, I ended up understanding that my final problem was that the user's directory didn't exists for the user I wanted to login with. To be more specific, I wanted to log with user alex, and /home/alex didn't exist, so it was not working. Everything is now working fine! Thanks a lot for pointing the way. You made me understand that the arrival directory was the key to my FTP issues – Alexandre Bourlier Sep 10 '15 at 0:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.