0

I realize that this is a question that has been asked before, but I've tried all of the suggestions I can find and nothing seems to work. Our database server for our medical system runs Windows 2003 server. Last month, suddenly, we were unable to RDP in to the server. However, our application server has been communicating with this server without difficulty and I can remote out from the database server to any location. My internet connection is also normal. No components have been changed (we use a Sonicwall firewall). I have removed our antivirus, freed up disk space, verified Remote Desktop is enabled, verified Terminal Services "Limit number of connections" Policy, verified Terminal Services RDP-Tcp properties, Checked the terminal service is listening on the port 3389, etc. Any suggestions woould be greatly appreciated. BTW, I am the administrator, but in name only. I do not have training in server administration, so I will need it kept fairly simple. Again, thanks for any help.

closed as off-topic by Esa Jokinen, kasperd, womble Oct 20 '17 at 2:25

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions should demonstrate reasonable business information technology management practices. Questions that relate to unsupported hardware or software platforms or unmaintained environments may not be suitable for Server Fault - see the help center." – Esa Jokinen, kasperd, womble
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Server 2003 is end of life. It no longer receives any patches or updates, even for critical security issues. It's irresponsible to continue using it, especially for medical data. Replacing this server should be job #1. – Joel Coel Sep 10 '15 at 1:03
  • 2
    "Our old, unsupported, unpatched server running a medical system started behaving weirdly. I tried removing antivirus from it ..." isn't gonna end well. One obvious thing you haven't mentioned - have you rebooted it? Can you describe what happens when you try to RDP to it - what errors you get, how far it progresses? Anything in the event logs on the server for an attempted connection? Have you tried it from different clients (Win (XP) / 7 / 8 / 10) ? Are you connecting from the same office or remotely? – TessellatingHeckler Sep 10 '15 at 1:51
  • Thanks for the reply. I have rebooted the system multiple times. I get the typical error when you cannot connect-"Remote Desktop cannot connect to the remote computer for one of these reasons: 1. Remote access to the server is not enabled. 2. The remote computer is turned off. 3. The remote computer is not available on the network." That's as far as I get.I have tried connected through Windows 7, Windows 8.1 machines. I've also tried to rdp from the server to itself and I get the same message. I have tried connecting bot remotely through a vpn and locally. – Merrick2 Sep 11 '15 at 3:09
  • Sonicwall still forward port 3389 to the correct IP ? – yagmoth555 Sep 12 '15 at 3:23
1

Honestly, I've seen this happen on a 2003 server before but it wasn't my server and the person who ran it wasn't really interested in fixing it. Check the related registry keys (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server) and see if anything in there looks hinky (particularly fDenyTSConnections). Hopefully that'll help. If not, check the event logs for information, as TessellatingHeckler suggested.

That said, I'd feel irresponsible if I didn't encourage you to upgrade this server to an operating system that's still in mainstream support. You also haven't said what database server you're running, but hopefully it's one that's still supported. You can get that information here. As Joel Coel pointed out in the comments, Windows server 2003 no longer receives security updates. You have a responsibility to the patients served by your facility to keep their data private. I'd look at migrating to a new server before spending too much time fixing the old, out-of-support one.

  • 1
    I appreciate the comments. Thank you. I'm sorry-I didn't give enough information. I absolutely realize the OS is at end of life. We have already moved to a new medical records system that is cloud based and runs on the newer Windows servers. My purpose is to solely use this for a read only backup of our old records. Unfortunately, this software is proprietary and will not run on Windows 2008 or 2012 server. My thought is to virtualize this current server but since we can't rdp in to the system, I can't upload it in to the new cloud server where it would be protected. – Merrick2 Sep 11 '15 at 3:01
  • Does event viewer say anything interesting? Also check the firewall. – Katherine Villyard Sep 11 '15 at 3:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.