1

I'm trying to install gitlist on my synology NAS (DSM 5.2).

I downloaded and configured gitlist in config.ini and pointed it to my repositories folder (/var/services/homes/git/repo).

But when I try to access the application I get this error:

Warning: is_dir(): open_basedir restriction in effect.
File(/var/services/homes/git/repo) is not within the allowed path(s):
(/var/services/tmp:/etc.defaults:/usr/bin/php:/usr/syno/synoman:/etc:/var/run:
/volume1/@tmp/php:/var/services/web:/var/services/photo:/var/services/blog:
/var/services/homes:/var/services/homes/git/repo) in 
/volume2/web/gitlist/src/GitList/Config.php on line 62 Please, 
edit the config file and provide your repositories directory

As you can see the folder (/var/services/homes/git/repo) is already present in the list of allowed paths.

Does anyone had the same problem or knows how to solve it?

  • Open base dir is a list of directories, you are trying to open the directory /var/homes/git, apparently. – AD7six Sep 11 '15 at 5:57
  • @ad7six, following your sugestion, I added both directories /var/services/homes/git and /var/services/homes/git/repo to the open_basedir and I get still the same error message. :-( – Joan Sep 12 '15 at 16:24
  • My mistake, not that then. Probably a good idea to remove open base dir - if not permanently, to verify if it is the primary reason things don't work. IMO open base dir is unnecessary, it is a poor substitute for proper file permissions. – AD7six Sep 21 '15 at 9:12
  • I removed open_base_dir and the application worked. So, yes, it loosk this is the primary reason. – Joan Sep 24 '15 at 8:43
0

The same thing was happening while I was trying to install Magento 2:

Exception #0 (Exception): Warning: is_dir(): open_basedir restriction in effect. File(/etc/pki/tls/certs) is not within the allowed path(s): (/var/www/:/tmp:/etc/pki/)

Turns out that the /etc/pki/ folder didn't even exist, I only had to create the directory to got it to work:

mkdir /etc/pki

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.