1

I cant start second NIC on Dell Poweredge 2950, OMSA installed, the NIC cards is BCM5708C ,version of Operating System Centos 6.7.

The first card worling correctly

[root@alfa ~]# ifup eth1
RTNETLINK answers: Device or resource busy
Failed to bring up eth1.

-

[root@alfa ~]# uname -a
Linux alfa.uskonnen.net 2.6.32-573.3.1.el6.x86_64 #1 SMP Thu Aug 13 22:55:16 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

-

[root@alfa ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth1
DEVICE=eth1
BOOTPROTO=static
ONBOOT=yes
NM_CONTROLLED=no
UUID="be0b2777-dc5c-421b-b3be-d0f5664f603f"
IPADDR=123.123.123.49
NETMASK=255.255.255.224
DNS1=1.1.1.1
DNS2=2.2.2.2.2
GATEWAY=123.123.123.62
TYPE=Ethernet
HWADDR=00:1a:a0:0d:3a:9c

-

cat /var/log/messages:
alfa kernel: bnx2 0000:09:00.0: firmware: requesting bnx2/bnx2-mips-06-6.2.3.fw
alfa kernel: bnx2 0000:09:00.0: firmware: requesting bnx2/bnx2-rv2p-06-6.0.15.fw
alfa kernel: bnx2: fw sync timeout, reset code = 5030024
alfa kernel: bnx2 0000:09:00.0: eth1: <--- start MCP states dump --->
alfa kernel: bnx2 0000:09:00.0: eth1: DEBUG: MCP_STATE_P0[00000106] MCP_STATE_P1[dffdffff]
alfa kernel: bnx2 0000:09:00.0: eth1: DEBUG: MCP mode[0000b800] state[80004000] evt_mask[00000500]
alfa kernel: bnx2 0000:09:00.0: eth1: DEBUG: pc[08006b88] pc[08006b88] instr[1440fffb]
alfa kernel: bnx2 0000:09:00.0: eth1: DEBUG: shmem states:
alfa kernel: bnx2 0000:09:00.0: eth1: DEBUG: drv_mb[05030024] fw_mb[00000023] link_status[0000f06b] drv_pulse_mb[000000$
alfa kernel: bnx2 0000:09:00.0: eth1: DEBUG: dev_info_signature[44564905] reset_type[01005254] condition[00000106]
alfa kernel: bnx2 0000:09:00.0: eth1: DEBUG: 000001c0: 01005254 4253800a 00000106 d7ffffff
alfa kernel: bnx2 0000:09:00.0: eth1: DEBUG: 000003cc: 44444444 44444444 44444444 00000a28
alfa kernel: bnx2 0000:09:00.0: eth1: DEBUG: 000003dc: 0004ffff 00000000 00000000 00000000
alfa kernel: bnx2 0000:09:00.0: eth1: DEBUG: 000003ec: 00000000 00000000 00000000 00a27657
alfa kernel: bnx2 0000:09:00.0: eth1: DEBUG: 0x3fc[0000ffff]
alfa kernel: bnx2 0000:09:00.0: eth1: <--- end MCP states dump --->
alfa /etc/sysconfig/network-scripts/ifup-eth: Failed to bring up eth1.

How it can be fixed? Please help

  • the output of ip link or ip addr would be useful. in the meantime, i can see one error in your ifcfg-eth1 file: DNS2=2.2.2.2.2 should actually only have four octets, not five. so it should read DNS2=2.2.2.2 – drew Sep 14 '15 at 22:53
0

I had a similar situation, although with different hardware. The problem turned out to be a firmware issue that I resolved by re-flashing the NIC. The question asks about Broadcom NICs on a Dell system, but my case is with Intel NICs on an Intel system. I'm not certain if there is any non-volatile portion of the firmware on Broadcom NICs or not, so this method might not have a similar method available for that system.

In my case, I had an Intel server board (S2600ST) with onboard Intel NICs. The NICs worked fine for PXE booting, and for handling out-of-band IPMI. The OS could even see the NICs... ifconfig would list the interfaces, but upon trying to bring the interface up, it would give the same error:

RTNETLINK answers: Device or resource busy

First, I tried to flash the BIOS/BMC/FRU. That didn't change the behavior, and the problem persisted. This would still be a good first step to take for most systems.

Next, I tried reflashing the NIC itself. Intel NICs need to be flashed to enable PXE booting and other preboot option ROMs. Knowing this, I installed Intel's bootutil and ran it. It listed every NIC in the system, after which I ran it with the the option to enable the PXE option rom:

./bootutil64e -FLASHENABLE -NIC=1

Running this flashes the entire NIC firmware, and doesn't just change a setting in a small nvram region. So even though I didn't change anything (as the PXE option rom was already installed/enabled), it reflashed the firmware.

Now a reboot is required. I rebooted the system, and the OS could now bring up the interface without errors, as well as use the NIC.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.