0

I booted up an Azure VM with Windows Server 2012 r2 and attached 5 additional Virtual hard disks to form a storage pool or a larger volume, but none of the disk/volumes are showing up in the Server Manager\File and Storage Services\Volumes\Disks. Am i missing anything?

  • Usually the disks appear on the fly under disk management since Windows 2012 R2 supports hot disk attachment, no kidding but have you tried turning it off and on again? – Noor Khaldi Sep 13 '15 at 19:57
  • No, it doesnt. Unfortunately i dont have enough points to post the image, otherwise i can share the screenshot. – Ilyas F Sep 14 '15 at 9:13
  • Like i have stated in the question, i got Win 2012 R2 with 5 additional Virtual Hard drives, but its displayed in the disks under my computer, but not under Server Manager\File and Storage Services\Volumes\Disks – Ilyas F Sep 14 '15 at 9:15
  • did you by any chance format the disks and create partitions on them? – Noor Khaldi Sep 14 '15 at 9:27
  • Do the disks show up in the Disk Manager? Have you attached empty disks or existing disks? – Peter Kirchner Sep 15 '15 at 8:11
0

Server Manager / File and Storage Services / Volumes / Disks only shows basic disks not dynamic disks. It could be very likely that you have created dynamic disks (e.g. in the Disk Management) and volumes on them. In that case they would show up in the Windows Explorer but not in the File and Storage Services.

You would need to convert your dynamic disks back to basic disks using the Disk Management. Conversation back to basic is not possible if there is already a volume on the disk. If there are volumes on the dynamic disk you would first have to delete the volumes.

enter image description here

  • Hi @Peter, .like you said all my volumes are basic and there is no volumes created and it is basically unallocated. but when i go to Server Manager\File and Storage Services\Volumes\Disks, it does nt show up at all, and its keep showing "Display willl be complete when the server inventory has finished". Usually how long it takes to show the disks in Storage Pools. FYI : win 2012 r2/A7 Series/Azure VM – Ilyas F Sep 15 '15 at 11:13
  • Usually it takes less than a minute. Today never more than 15 seconds. Have you tried to create a new VM to check whether there's the same behavior? The described behavior sounds strange, sounds like a corrupt configuration of some kind. – Peter Kirchner Sep 15 '15 at 14:32
  • Looks like this is an issue with the Azure VM Server with Win 2012 r2. I have raised a ticket with Microsoft storage team and awaiting their response. – Ilyas F Sep 16 '15 at 11:10
  • Would be interested to hear the end of the story! :-) Btw, did you test if you have the same behavior on another VM? – Peter Kirchner Sep 18 '15 at 5:38
  • Hi Peter, I will share the end of the story once i receive the assistance/solution from MSFT. BTW, i did test the same behavior with a smaller set of disks on A3 Server, it didn't happen. – Ilyas F Sep 18 '15 at 16:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.