3

Recently I setup a new box with Debian 8 Jessie (I used Debian 6 and 7 on other boxes). I was disappointed to see the startup messages only on 2 or 3 text lines. No more list of startup services written "OK" or "Failed", or filesystem details with fsck etc.

Searched the web, I found to remove the "quiet" option from the /etc/default/grub file. I did that, recovered the messages I used to see on previous versions but also a lot of garbage, making the text scrolling so fast I couldn't read anything.

I liked to see the "light" messages before to have an overview of the box health when restarting. How could I have this back on Jessie ? (Checked on the older boxes, the "quiet" option was present, so it seems the difference is not there).

I don't care about having a "beautiful" startup screen, these are only servers ...

Thanks for your help

  • 1
    I also liked being able to read the start-up messages and I too disabled the quiet GRUB option after installing Debian 8. Then I realised that the messages flew by too quickly to read. I just accepted this as a consequence of the move to Systemd. After all, one if its advantages is fast start-up. – Anthony Geoghegan Sep 15 '15 at 10:06
  • 1
    Thanks for pointing me out the systemd move, I searched the web to understand the thing, and I'll go the same way than you : accept ... – Sierramike Sep 23 '15 at 10:21
5

As it was already pointed out, Debian 8 Jessie comes with systemd init system by default, which behaves differently than older SysV init system. To get your startup messages back you need to make following changes:

  1. Add systemd.show_status=1 to the kernel options list. The easiest way to do so is to add to the /etc/default/grub:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet systemd.show_status=1"
    

    and run update-grub2.

  2. In principal, that should be enough to get your messages back on the console. But, there is another catch - systemd is also controlling TTY allocation now and invocation of getty, so tty1 will be cleared before the login prompt is shown. To disable clearing tty1 you need to create file, for ex. noclear.conf, in /etc/systemd/system/getty@tty1.service.d/ directory with the content:

    [Service]
    TTYVTDisallocate=no
    

With those two steps you'll get your startup messages back.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.