3

some help needed.

I have/manage a samba share at work. It works fine for everyone except one user. I've tried all I can think now, so now I hope for some new input.

$smbclient --list LOCALHOST

as my user works fine.

$smbclient --list LOCALHOST --user charlottepa

just gives me "session setup failed: NT_STATUS_LOGON_FAILURE".

any other user works just fine, but not this one. I've tried to set the password again with both "passwd" and "smbpasswd -a" and restarted the smbd after the change. No luck.

tail /var/log/samba/log.172.20.107.5 (the localhost)

[2015/09/15 17:14:09.756209,  0] ../source3/smbd/smbXsrv_session.c:1265(smbXsrv_session_update)
  smbXsrv_session_update: global_id (0xefcb8bb0) store failed - NT_STATUS_INVALID_PARAMETER
[2015/09/15 17:14:09.756269,  0] ../source3/smbd/sesssetup.c:374(reply_sesssetup_and_X_spnego)
  smb1: Failed to update session for vuid=62513 - NT_STATUS_INVALID_PARAMETER

How can I reset her access so that she can use or samba share again?

Server=[Samba 4.1.6-Ubuntu]
It's an Ubuntu 14.04 LTS server. (3.13.0-62-generic)
  • smbpasswd -a is only for adding new users. Have you tried it without the -a ? – Eddie Dunn Sep 15 '15 at 16:16
  • Yes I've tried without the -a option. Doesn't help. – Stefan Ericsson Sep 16 '15 at 9:59
5

I finally manage to solve the problem. Using "pdbedit -L" I found that names containing Swedish characters didn't display properly. And after changing them with "pdbedit -r --fullname" it now works. I did write the same name again, but now they display correctly. So it looks like perhaps Samba changed the encoding for the user database.

Maybe this can help someone else.

  • This helped me also with Turkish chars in name like ü ğ ş ç – Mert Gülsoy Nov 20 '15 at 16:32
1

Thanks a lot for your post, it is useful.

I've hit the same situation on CentOS 7 with latest Samba (as of June 2018).

I've accidentally inserted a bad character in the "Full Name" (using chfn command); Samba stubbornly refused to connect from other boxes. The solution was to correct the "Full Name" using pdbedit, as described in your original post.

  • Gotta love stackoverflow for these underappreciated but still given answers! :D – Aiyion.Prime Aug 24 at 8:05
0

is it possible the user accidentally got disabled? Try re-enabling the user with:

smbpasswd -e <user>

Other than that you could always try:

smbpasswd -x <user>
smbpasswd -a <user>

To delete and re-add the user

  • Interesting effects. I tried -e without success. Then I tried -x. And then it worked with smbclient on the server, but not from her Win7. I then added it again with -a and got back to the same result with "session setup failed". – Stefan Ericsson Sep 16 '15 at 10:02
0

I just came across the same problem with a different cause: smbXsrv_tcon_global.tdb had reached 4GB in size and couldn't grow any more.

Deleting /var/lib/smbXsrv_tcon_global.tdb and restarting Samba cured the problem.

I believe that this is related to a bug in Samba which occasionally causes a crash in smbXsrv_session_logoff_all when a client disconnects.

This was an a RHEL 7.1 system running Samba package version samba-4.2.3-10.el7.x86_64.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.