68

I get the error:

(error) NOAUTH Authentication required.

When in redis-cli and trying to display the KEYS *. I've only set a requirepass not an auth afaiac. I'm in the redis.conf but do not know what to do.

7 Answers 7

37

Setting the requirepass configuration directive causes the server to require password authentication with the AUTH command before sending other commands. The redis.conf file states that clearly:

Require clients to issue AUTH before processing any other
commands. This might be useful in environments in which you do not trust
others with access to the host running redis-server.

3
  • 15
    so, what are the exact steps to fix the problem?
    – serge
    May 20, 2019 at 8:52
  • @Serge Uh... you comment the requirepass part in the redis.conf file? Jun 2, 2020 at 7:01
  • 1
    This answer explains why, but no steps to fix OP's question.
    – dylanh724
    Aug 28, 2022 at 3:39
64
1. redis-cli
2. auth yourpassword
3. shutdown
4. sudo service redis_6379 start
2
  • 5
    Simple, concise, and to the point!
    – Edd
    Mar 5, 2019 at 20:55
  • This is the true answer.
    – dylanh724
    Aug 28, 2022 at 3:40
16

first run

redis-cli

then after the prompt run

127.0.0.1:6379> AUTH your_password

if all ok you get the OK

8
  1. Make sure you have redis-cli installed.
  2. Just use following command.

    redis-cli -h host.domain.com -p port -a yourpassword

3

comment requirepass (line 480 mostly) in redis.conf file if uncommented.

1
  • 1
    Usually have a password for security, probably best to provide a solution than enables the ability to put in the password Apr 23, 2020 at 7:48
1

specific your redis password in the redis-cli command line eg:

redis-cli -h 127.0.0.1 -p 6379 -a "$your_password"

check your $your_password.

It's recommend to add double quote to the password on the command line.

2
  • The flag is incorrect here it should -a or --pass for the password.
    – Danny G
    Apr 9, 2023 at 2:45
  • 1
    @DannyG thanks. I‘ve corrected my typo
    – jianyongli
    Apr 9, 2023 at 11:22
0

NOAUTH requires to authenticate via AUTH method before executing any get/set/etc. call, in predis that can be done via the auth() method, for example:

    $predisClient->auth('username', 'password');

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .