1

I deactivated data deduplication on one of my drives because it doesn't work well with the backup system.
I then started an unoptimization job in Administrative PowerShell. After that I realized I didn't put the priority up high so the job runs faster since there is no load on that server at the moment. So I tried stopping the job and got this:

PS C:\Windows\system32> Stop-DedupJob  
Stop-DedupJob : The term 'Stop-DedupJob' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.  
Stop-DedupJob  
+ ~~~~~~~~~~~~~  
+ CategoryInfo          : ObjectNotFound: (Stop-DedupJob:String) [], CommandNotFoundException
+ FullyQualifiedErrorId : CommandNotFoundException

I was able to do Get_DedupJob at first but now I get the same error as if the cmdlet were removed.... But an Unoptimization Job is still running... How can I use the cmdlet without re-enabling the deduplication on the volume?

1

Make sure the Deduplication module is imported in Powershell, otherwise the commands will not be available:

Import-Module Deduplication

| improve this answer | |
1

For some reason those cmdlet are availible using the 64 bit version of powershell. It is shown as Windows PowerShell in the menu, without the trailling (x86). If it is not shown in the applications menu just search for it.

You should then have access to the cmdlet for deduplication.

| improve this answer | |
  • I must say it is really weird because from memory it worked from the x86 powershell. It is even weirder that the powershell is not proposed in the fullscreen menu. – Gopoi Sep 17 '15 at 14:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.