1

I have created a basic WinPE 10 boot.wim, which is deployed by PXE through WDS. Unfortunately, when it attempts to launch setup.exe the error:

Windows could not determine the language to use for setup. Error code: 0x80004005.

I can't get around this error!

To create the boot.wim, Windows 10 ADK was installed (on Windows 7 Ent), the WinPE.wim boot file from the ADK was mounted and the following packages were added:

  • Microsoft-Windows-WinPE-LanguagePack-Package~31bf3856ad364e35~x86~en-US~10.0.10240.16384 (Language Pack)
  • Microsoft-Windows-WinPE-Package~31bf3856ad364e35~x86~~10.0.10240.16384 (Foundation)
  • WinPE-LegacySetup-Package~31bf3856ad364e35~x86~en-US~10.0.10240.16384 (Language Pack)
  • WinPE-LegacySetup-Package~31bf3856ad364e35~x86~~10.0.10240.16384 (Feature Pack)
  • WinPE-Scripting-Package~31bf3856ad364e35~x86~~10.0.10240.16384 (Feature Pack)
  • WinPE-Setup-Client-Package~31bf3856ad364e35~x86~en-US~10.0.10240.16384 (Language Pack)
  • WinPE-Setup-Client-Package~31bf3856ad364e35~x86~~10.0.10240.16384 (Feature Pack)
  • WinPE-Setup-Package~31bf3856ad364e35~x86~en-US~10.0.10240.16384 (Language Pack)
  • WinPE-Setup-Package~31bf3856ad364e35~x86~~10.0.10240.16384 (Feature Pack)
  • WinPE-WDS-Tools-Package~31bf3856ad364e35~x86~~10.0.10240.16384 (Feature Pack)
  • WinPE-WMI-Package~31bf3856ad364e35~x86~~10.0.10240.16384 (Feature Pack)

International settings are:

  • Default system UI language : en-US
  • System locale : en-US
  • Default time zone : Pacific Standard Time
  • User locale for default user : en-US
  • Location : United States (GEOID = 244)
  • Active keyboard(s) : 0409:00000409
  • Keyboard layered driver : PC/AT Enhanced Keyboard (101/102-Key)
  • Installed language(s): en-US Type : Fully localized language.

The WDS server is a 2012 R2 box. No Unattend files for WinPE being used at this stage.

3

Your Boot.wim bootable image must have a lang.ini file within the \sources directory containing i.e.

[Available UI Languages]
en-US = 3

[Fallback Languages]
en-US = en-us
  • Bah, I completely forgot about this step (and forgot to document it). Had to do the same for previous PE 3+ boot images in the past. I MUST put it in the documentation this time. Thanks, kudos applied. – MrBeatnik Sep 18 '15 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.