2

The Problem

I have a Windows Server 2008 R2 machine, which got serious problems with it's .Net Framework installation.

The problem came to light when Windows Updates related to .net 4.5.1 started to fail with error code 64C. Affected Updates that i cannot install anymore:

  • KB2972107
  • KB2972216
  • KB2978128
  • KB2979578
  • KB3023224
  • KB3035490
  • KB3037581
  • KB3074230
  • KB3074550

All of these are listed as Security Updates for .NET Framework 4.5 Other Windows Updates install fine.

What i already have tried to solve the issue:

  • Repair and uninstall .net 4.5.1 form Programs and Features Panel
  • Repair and uninstall with a freshly downloaded offline installer of .net 4.5.1
  • Install a freshly downloaded offline installer of .net 4.5.2
  • Install a freshly downloaded offline installer of .net 4.6
  • Manual installation of the failed .Net updates

All of those things gave me the following Error:

The installed product does not match the installation source(s). Until a matching source is provided or the installed product and source are synchronized, this action can not be performed.

Contact your administrator or product vendor for assistance. If there is a matching installation source type it below or click Browse to locate it.

This (existing) path is preselected:

C:\Windows\Microsoft.NET\Framework64\v4.0.30319\SetupCache\v4.5.50938

If i just click OK the following error appears:

The path 'C:\Windows\Microsoft.NET\Framework64\v4.0.30319\SetupCache\v4.5.50938\netfx_Full_GDR_x64.msi' cannot be found. Verify that you have access to this location and try again, or try to find the installation packages 'netfx_Full_GDR_x64.msi' in a folder from which you can install the product Microsoft .NET Framework 4.5.1

That file exists in that folder, and i can access it. If i try to execute it though, it gives me the following error:

Error applying transforms. Verify that the specified transform paths are valid.

The next thing I tried was to use the .net Framework Repair Tool (http://www.microsoft.com/en-us/download/details.aspx?id=30135), but that one does not work either. After the (ineffective) repair of the Windows Installer, it works for quite some time and then says that it is unable to complete the repair. It collects a bunch of logsfiles, though, and a quick glance gives me the following return code on the repair: 80070658 Googling does not really find much on that code regarding .net framework.

The System

Some words about the System: The Server is one of our many VMs on our ESX Cluster, and as far as i know, the only one with this problem. I would strongly prefer not having to reinstall the machine, since that machine provides several license servers which are bound to the machines specific id. Everything (besides the windows updates) works on the System, so a solution that allows me to simply uninstall .net 4.5.1 would be enough. I need this mainly fixed, because Windows Updates are audited regularly, and failed updates have to be fixed.

1

Try first to repair .net with this tool: http://www.microsoft.com/en-us/download/details.aspx?id=30135

If it won't help, try uninstall it cleanly with this: http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

Then install again from freshly downloaded .net 4.6 installer: http://www.microsoft.com/en-us/download/details.aspx?id=48137

Finally you can verify the integrity of .net instalation with this tool: http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.