0

Using Debian Wheezy here.

The last release of OSX aka "El Capitan" doesn't like our Freeradius 2.2.1 server using libssl 1.0.0 and ssl keysize of 2048

Apparently the only way to make it work is upgrading to 2.2.8 version and using libssl 1.0.2.

PROBLEM:

  • Debian last freeradius version supported (on backports) is 2.2.5
  • Debian last libssl version supported is 1.0.0

WHAT I'VE DONE:

  • Compiled freeradius 2.2.8 and made .deb packages.
  • Used libssl 1.0.2 version (on experimental packages).

SO ?

  • libssl 1.0.2 needs libc6 but it's really unstable and cracks often (also from experimental packages)

I don't know what else I can do... I imagine everybody is having the same issues so I guess somebody could have found the solution.

Any ideas?

0

the solution was to create a SSL Certificate with the tools provided by freeradius (not provided in the Debian packages).

  • Can you be more specific about the differences between the certificate that worked / didn't work? – johnny Dec 6 '15 at 22:33
  • I couldn't say... There were many configs to do manually, and nothing worked... But the scripts provided by freeradius for creating the certs worked very smooth. – uDalillu Dec 7 '15 at 11:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.