8

I have an old Netgear GS700TP that can only be managed via its web ui. For the most part, that works ok, but the page specifically where you assign ports to a specific VLAN doesn't render in current chrome, firefox, IE, etc.

Anyone have any tactics for such situations? Ways to render the web interface when you don't have access to old browsers?

Alternately, anyone have experience with the Assign VLAN interface specifically on the GS700TP and maybe have a way to fake it with curl or another tool?

  • 6
    IE's compatibility mode? I also find it helpful to put such things at the top of the list of garbage to be thrown out and replaced. – Michael Hampton Sep 17 '15 at 22:13
  • 4
    That switch is 8 years old!! I've been in the same situation and just updated because the cost of the equipment paled in comparison to the time and frustration it saved. – ewwhite Sep 17 '15 at 23:49
14

While I can't remember the model, I have defniitely come across this issue before, particularly with Netgear switches and their VLAN configurations.

My solution was to download and use an old version of Firefox Portable - no installation required and can run as an unprivileged user. I would suggest you search around for which versions of the browsers will work with your devices, but I think I was using Firefox 25.

In addition to yagmoth555, I would recommend replacing the switch with either a newer model or a different manufacturer.

  • 3
    Firefox Portable Edition indeed was an easy solution. I had to go all the way back to 4.0, but it was possible! – Dan Pisarski Sep 18 '15 at 0:09
3

IE Compatibility mode, Virtualize IE6.

If you cant, use virtualbox and install an xp only for that task..

I strongly recommand to change the appliance.

  • Yeah, I hear you on swapping it out... out of budget but maybe needs to be done! – Dan Pisarski Sep 17 '15 at 23:02
  • @DanPisarski No worry, as like at my job I still have a old XP laptop with a serial port on it. Some gear even need old java1.4. – yagmoth555 Sep 18 '15 at 0:50
3

Have you tried the linux tools "links" or "lynx"? They are command line based so should work with normal pages. If it is based on JavaScript it probably won't work.

Do you actually see why it is failing on modern browsers? Try the Developer Console in Firefox (alt/cmd+shift+L). Maybe you get better answers with more details.

Also consider replacing it, newer device have better protection against attacks and you still get software updates that make the webinterface run with current browsers. ;)

1

The easiest method (if it works) would be to use the Compatibility Mode in a current version of IE. This should make the web app usable without needing to install any special tools.

It's possible (though unlikely) that something on the VLAN page is accidentally blocking newer browser based on some test of the agent string. It may be the case that the site actually works fine if your browser simply pretends to be older than it is. For most browsers this can be done without installing any extensions, using only the built in developer tools.

Failing those approaches, as Craig points out, old version of Firefox are available. You can have several version installed side-by-side but I believe you need to turn automatic updates off (or they'll all automatically upgrade themselves).

On the heavier-but-sure-to-work side of things, Microsoft have some great IE virtual machine images for download along with instructions on how to work around activation issues with the OS. All totally legit and exceeding handy for legacy web tools like this.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.