0

I am trying to set up xmlsec1-openssl in order to install LASSO on an Amazon AMI Linux. I have xmlsec1 1.2.7-4 setup for an x84_64 arch. I downloaded the RPM for the xmlsec1-openssl 1.2.7-4 (x86_64) from here

When I execute yum install openssl-1.2.7-4.x86_64.rpm , I get an error stating that libcrypto.so.5 and libssl.so.5 are required and are missing. I have checked in the /usr/lib directory and see libssl.so.10 and libcrypto.so.10 in there. Is this an openssl issue? What can I do now so I can install the package.

  • That RPM is not meant for Amazon Linux. It's also many years old. – Michael Hampton Sep 21 '15 at 6:06
  • What can I do to set it up on Amazon Linux? Any repository from which the package might be available? – user312369 Sep 21 '15 at 6:07
  • First, exactly which "LASSO" are you trying to install? Unfortunately there are apparently several projects with this name. – Michael Hampton Sep 21 '15 at 6:08
  • trying to install v2.2 of the Liberty Alliance SSO(LASSO) lasso.entrouvert.org – user312369 Sep 21 '15 at 6:09
  • Then you have two questions: Why an old version? And why not use a Linux distribution that already includes it, such as Fedora? – Michael Hampton Sep 21 '15 at 6:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.