0

Windows Server 2012 in a domain environment.

I cant seem to be able to do anything in Task Scheduler anymore. I might as well mention that my user is a domain admin.

When attempting to disable a present task I get:

"The user account you are operating under does not have permission to disable this task".

When attempting to create a new task with just about any user including the SYSTEM account which I had used numerous times before I get:

"The user account you are operating under does not have permission to disable this task"

The funny part is that deleting a task does work. What could have possible went wrong here?

Update:

I discovered I'm having issues accessing c:\windows\system32\tasks\Microsoft\Windows. It always gives me "Access Denied" even though I've taken ownership over the folder for some reason.

  • With an domain admin account, does it work ? – yagmoth555 Sep 21 '15 at 13:59
  • Seem corrupt, can you validate c:\windows\system32\task, and HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\. Last option would be to backup them, and erase the folder and registry hive – yagmoth555 Sep 21 '15 at 14:57
  • Well, I backed everything up and erased TaskCache. Unfortunately that didnt help either besides removing ALL tasks including the system ones. Still getting "the user account is unknown..." when trying to create a new task though. However, I did find out something is indeed messed up with the c:\windows\system32\tasks\Windows folder's permissions. I'm unable to access it even if I take it's ownership which is weird because I have no problems doing so on a different server. – JustAGuy Sep 22 '15 at 7:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.