1

I followed the instructions for installing redis from here.

I also ran:

make test

and all the tests passed. Then:

make install

and that appears to have worked. I've done all this as root.

But install really appears to have done very little if anything. I can't start redis as a service with:

start redis.service

which gives:

start: Unknown job: redis.service

and there are no redis directories under /etc/init.d. There must be some simple command I can run.

The executables have been correctly placed in /usr/local. If I run redis-server, it definitely runs, but quits when I Ctrl-C. Do I just need to run this with nohup? I want redis to run upon startup and this seems unreliable.

  • 1
    Try following the directions given in the tutorial instead. – Michael Hampton Sep 22 '15 at 20:42
  • I missed a step. The internet has ruined my brain. – AKWF Sep 24 '15 at 16:00
1

There are other way's of doing this, but not being familiar with redis and its specific limitations: one easy option would be to add your launch line to

/etc/rc.local

Anything listed there will run on boot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.