0

I'm on my local machine. I'm a dev guy with no idea about ops. After selecting us-east-1 for my region after running eb init on the command line, I get this:

ERROR: The current user does not have the correct permissions. 
Reason: Operation Denied. Signature not yet current: 
20150922T194753Z is still later than 20150922T194701Z (20150922T194201Z + 5 min.)

I've looked around for answers and it appears it's a time zone issue experienced by others after their applications are already deployed and they solved the problem by syncing the time zones of their already launched EC2 instances. But, I haven't deployed to EB yet, and I don't have an associated EC2 instance. I tried aligning my system clock and time zone to us-east-1's time zone using sudo dpkg-reconfigure tzdata but the error persists.

So how do I get past this?

2

Your problem is not a timezone issue. If it was a timezone issue, then the time difference would be in increments of hours rather than minutes.

Your system clock is 5 minutes, 52 seconds ahead of Amazon's clock, which is greater than the variance allowed by Amazon's signature algorithm (5 minutes).

Compare your system time against a known good reference, such as http://www.timeanddate.com/worldclock/ and set your clock correctly. Most likely, you'll see that your clock is 6 minutes ahead.

If you set your clock 6 minutes back, your commands should execute correctly.

  • To set clock correctly, launch this comman : sudo hwclock --hctosys – elhostis Dec 6 '16 at 8:58
0

Set your system clock and time zone selection, on your local machine, correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.