4

I installed Docker according to this manual and triggered the following command:

sudo chkconfig docker on

Everything works great, but when I reboot the system, Docker daemon is not running.

I also tried this command, but without success.

sudo systemctl enable docker

My OS is CentOS Linux release 7.1.1503 and Docker version 1.8.2

How do I ensure guaranteed start of Docker after a reboot??

  • What is the output of sudo systemctl start docker and sudo systemctl status docker? – Henrik Pingel Sep 23 '15 at 11:08
  • here is the output of sudo systemctl status docker after reboot: goo.gl/21bB2I. When I run sudo systemctl start docker, Docker normally works – jjaros Sep 23 '15 at 11:33
2

I solved my problem.

I had SocketGroup=docker configuration in /usr/lib/systemd/system/docker.socket file, but at Docker startup time a group docker did not exist because I manage my Linux identities (users, groups, etc) with FreeIPA and this starts after Docker.

Solution

Add this line to /etc/group file:

docker:x:GID:

GID is a same number as is configured in FreeIPA for group docker.

| improve this answer | |
  • Docker by design does not use any 'external' NSS module and expects only users to exist in /etc/passwd and groups in /etc/group files. – abbra Sep 24 '15 at 5:37
  • my hero.... found this 3 days wondering through all the "overflow" sites and endless gitlab issues. and many many re-installations of docker engine. i have installed docker in the past year in many machines (on-prem and aws, windows, linux), this week, 3 machines have this exact same issue. 1 in aws (docker daemon starts fine before) and 2 on-prem machines with no docker installed. very weird. the os I was troubleshooting was ubuntu 18.04, docker installation step was followed exactly as recommend from the official docker web page. – pangyuteng May 7 at 1:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.