2

I'm not able access samba from a windows 10 machine which is having a mail user account.However,when i login with a local user account i'm able to access the samba share.

I went ahead and captured the Wireshark traces and i was able to understand that i'm not getting response for setup andx Request when i use the mail account.

Can anyone help me on this case?I think i will have to do some policy changes in windows client side to enable the access. enter image description here

I'm able to access the share without any problem when I use the local user account.Problem is only observed when i try to access it using a client with mail user account.

Samba Version is 2.2.12

0

As I suspected the root cause of the issue was due to the type of user account.The host user account was with an e-mail account.

The problem arises only when the user account is of with more than 20 characters.

I used the user account which is having 30 characters.

As per the Samba version 2.2 the maximum characters accepted for username is only 20.This limitation is implied by the samba protocol. To confirm this hypothesis I went ahead and created a user account with less than 20 characters and the samba connectivity works fine with the email account in Windows 8.1.

This particular scenario will not happen when the client is accessing the samba share with a local user account because Windows Specification itself limit the maximum characters for user account as 20.

Source: https://msdn.microsoft.com/en-us/library/ms679635.aspx?f=255&MSPPError=-2147217396

Does anyone know how to solve this problem anyway from the client side? If we can disable the authentication at client side then i think it should be possible. I also found another link which I'm going to try now. https://techjourney.net/cannot-connect-to-cifs-smb-samba-network-shares-shared-folders-in-windows-10/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.