0

I have a domain registered with Fasthosts (animesoc.co.uk). I've recently hosted a forum on an external server (with IP address 51.254.128.170), and pointed the subdomain http://forums.animesoc.co.uk/ to this by adding the corresponding A record.

The issue is that when I try accessing 'forums.animesoc.co.uk' through a browser (tried from multiple different computers), it keeps switching between the website I actually want and a blank domain parking page with advertisements. It resolves to the IP address I mentioned above for about 1 hour or so, then starts giving me the domain parking page, switches back again to the forums and so on and so forth.

On using a DNS resolver service like http://tracert.com/resolver to check what the 'forums' subdomain resolves to, I get the following result

Resolution of forums.animesoc.co.uk resulted in the following IPv4 addresses:

51.254.128.170

213.171.195.105

I'm not sure why it's resolving to two IP addresses when I have only the single A record for forums (pointing to 51.254.128.170). Furthermore, I do not have the IP '213.171.195.105' present anywhere in my DNS settings so I'm not sure where that's come from.

I assume that the switching between the actual website and the domain parking page is occurring due to the subdomain resolving to this extra '213.171.195.105' IP address as well. How can I make the subdomain 'forums.animesoc.co.uk' resolve to just one single IP address (51.254.128.170)?

  • As you've identified, your nameservers are returning multiple IP addresses for that A record. We cannot troubleshoot this with the information you've provided. This is a configuration problem in the DNS server software, and if you are 100% certain that you are making the changes in the correct web interface the problem will need to be discussed with the product's support eam. – Andrew B Sep 23 '15 at 19:03
  • Did you make this change today? You may simply have seen old, cached DNS records. I no longer see the livedns IP address. – Michael Hampton Sep 24 '15 at 0:50
  • @MichaelHampton, the problem was with the domain host as Andrew suggested. They fixed it pretty quickly, which is why you must've seen the corrected result when you checked. – Noble Six Taniguchi Sep 24 '15 at 12:47
0

The problem turned out to be with the domain host's settings as Andrew suggested in the comments above. The issue was resolved after I contacted them to remove the rogue A record from the domain.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.