14

Would anyone know why after an RDP session either from my smartphone or from another PC, when I wake my computer and then proceed to log in, I get a black screen with cursor. I am running Windows 10 Pro 64bit, and haven't had this problem before. After the remote desktop session, it lets me get a lockscreen and prompts me to log in with my password but afterwards, either hitting enter or the arrow, I just get a black screen and the cursor. I am not able to hit any shortcuts or keypresses to make anything come up. ctrl+alt+del, ctrl+shift+esc, alt+f4, nothing seems to work. I only have one monitor so it's not an issue with windows not being able to recognize my default display like other Windows 10 users have been having, this seems to be different.

8

The issue was actually caused by Nvidia. Their Geforce Experience program was updated recently and their "Share" feature was updated and when enabled, that's when the problem happened. As soon as the feature was disabled on the PC i was remotely logging in to, the issue was fixed.

  • Do you mean "Shadow Play"? I've disabled this, but still have the issue. – M-Pixel Apr 22 '16 at 20:28
  • This seemed to solve the problem for me a few months ago, but now it is back. I have removed GeForce Experience since they started requiring a login to use the application, so it must be something else. – Dolphin Dec 6 '16 at 17:38
  • Are you using the app or the same rdp that comes preinstalled in windows accessories? I've had this issue using the app for older OSs. – veel84 Jun 30 '17 at 1:37
  • I had the same issue and I must say that GeForce Experience is really a bad piece of sw unless on a gaming-only PC. – Marco Aug 23 '17 at 12:15
  • This is correct, but as of Apr. 2018 this feature is called "In-game overlay". – dantheman2865 May 3 '18 at 2:16
4
  1. Try to kill your session on the remote server, if this is not possible. Give the machine a reboot if possible.

Next step is to disable Bitmap Caching in your rdp client.

  1. Open RDC -> Show options -> Experience -> Uncheck: "Persistent bitmap caching"

  2. Reconnect.

  • Forgot to mention that rebooting fixes the issue, but it happens every time I remotely access my PC and rebooting is not a permanent fix. And the problem is not with the remote access itself, that works fine. The problem is that after I terminate the session on the client, the desktop I was remotely logging into has the problem. After the rdp session, I'll actually go to the computer itself and log in locally and the issue happens with the black screen. – TheWizKid95 Sep 24 '15 at 16:55
  • Can you provide some more information about the hardware that you're running. And can you ping both machines when the issue occurs? – Smeerpijp Sep 24 '15 at 17:19
  • Running Windows 10 Pro 64bit on a custom built PC. Sabertooth Z87 mobo, i5-4690, 16GB Ram, 250 GB Samsung Evo SSD. Everything else shouldn't be relevant, but I can give you the info if needed. Also, I can ping the computer with a smartphone within the LAN before and after I log in to the computer locally. Also, issue happens with built-in NIC on mobo and with dedicated Intel gigabit NIC – TheWizKid95 Sep 25 '15 at 3:56
  • Totally forgot the graphics card, its a Nvidia Reference GTX 770 – TheWizKid95 Sep 25 '15 at 17:06
  • Can you try the following? Start a new RDP client on your desktop but BEFORE you click CONNECT, click the SHOW OPTIONS link, click the DISPLAY tab and set the DISPLAY CONFIGURATION to a low resolution like 640×480. I've also found this MS page, though i dont know if it is relevant for your OS. Maybe you can give it a try: support.microsoft.com/en-us/kb/3016725 – Smeerpijp Sep 26 '15 at 8:17
1

Late to the show, but for future reference, try disabling shadow play. I had exact same issue on my LAN & WAN.

1

This RDP issue goes back to Windows XP, and still effects Windows 10; it seems to occur after having a network connectivity issue when connecting an RDP session.

If the common solutions do not work (fe. ctrl-alt-end): log in as another user.

In other-words, to be able to remotely workaround this issue: have a second account to connect with, in-case the primary account's session breaks during another RDP session.

0

I had the very same issue

Turning off fastboot as mentioned here solved it for me.

" This feature only works when you do a SHUTDOWN and then Boot. It doesn't effect a RESTART. To turn it off or on... Go to Control panel...Power Options, and select Choose What the Power Buttons Do on the left. Then select Change Settings That are Currently Unavailable near the top center of screen... Lower down on the window, uncheck Fast Startup."

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.