9

When I start an Aws Ec2 Windows 2012 R2 instance it always comes with a default en-US locale.

However I need to change two of the existing instances to be en-GB as if they were installed like that in the first place. Which is to say I need to change the locale to en-GB for all users including system users like Network Service or Local Service.

Is there a way to do this?

I have tried in powershell Set-WinSystemLocale en-GB but even though I get no error it does nothing even after a reboot.

Thank you for any help.

  • Should have put above was really hoping to be able to do this without a registry hack. If I have to I guess I have to. – Barbary Sep 27 '15 at 9:31
3

This set of instructions I found for Windows 7 on windows.microsoft.com seems to work:

  1. Open Region and Language by clicking the Start button, clicking Control Panel, clicking Clock, Language, and Region, and then clicking Region and Language.

  2. Click the Administrative tab, and then, under Language for non-Unicode programs, click Change system locale. If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

  3. Select the language, and then click OK.

  4. To restart your computer, click Restart now.

-1

Try to copy locale settings from current user registry to the .DEFAULT key or use an IntlCfg utility.

  • 1
    Link doesn't work. And I could do with some more verbose instructions not knowing where to look in the registry. – Barbary Sep 27 '15 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.