0

I have this issue when I try to copy files over my network (from PC to NAS). The first file seems to copy without a problem until it reaches 99%. It hangs for minutes and fails eventually.

Let me summarize my equipment:

  • NAS: Brand new Synology RS815 with 4x3TB in RAID10 configuration
  • Transfer medium: CAT6 cabling
  • Switch: Cisco SG500-28P
  • Patch Panel: Tried T568A and T568B termination on the patch panel. No difference there.

I'm building up my network and connected already a few cables to the patch panel. My PC is connected to the switch without use of the patch panel (RJ45 connector on the cable). The NAS is placed near my PC for testing and is connected to a cat6 wall socket. The other end of the cable is connected to the patch panel where it is patched to the switch. I can browse the NAS, manage the NAS by web interface I believe it has something to do with the wiring on the patch panel or with the switch. When I connect the NAS on another small switch near my pc, I don't have the issue.

EDIT: I figured out that it has something to do with my static IP configuration. After putting my NAS and Switch to DHCP, the transfers go without a problem. I'm confused, because my setup is pretty straight forward. However, I nerver worked with a L2/L3 switch.

My internet provider has a modem with 4 ethernet ports and allows me to go online with 4 devices (wow.. thank you Telenet. 4 devices!! not..). Their modem is also functional as router but has not many features. From my modem I go to my own Netgear router (IP of the Netgear in the DMZ of the ISP modem). From that netgear, I go to the cisco swtich.

How would you config the network? The Netgear has a DHCP server, the Cisco switch has a DHCP server and also the Synology NAS has a DHCP server.

  • I connected the NAS directly to the Cisco switch and have still the same issue :-/. – Mr. T. Sep 26 '15 at 11:50
  • My guess is the NAS. Why not try copying the same file or files from PC to PC? That will give you a better idea of where the problem lies. – joeqwerty Sep 26 '15 at 14:49
  • It had something to do with my static IP configuration. Which I don't understand, because it is straight forward :-s – Mr. T. Sep 28 '15 at 18:57
  • 1
    @TonyVerbert Do you want us to troubleshoot your current setup or recommend a new one? Either way, we need a lot more information. – David Schwartz Sep 28 '15 at 19:24
  • @DavidSchwartz: Troubleshoot the current one, would be great. (refreshing my memory actualy :)) If I'm correct, you need to enter the following settings on every device you want to have a static IP: - Default gateway (= the IP of my router? Or do I enter the IP of my switch here?) - IP address - Subnet mask - DNS : I have DNS servers from my ISP, but I prefer the Google DNS servers. Or do I enter the IP of my router here? – Mr. T. Oct 3 '15 at 11:42
0

I have seen similar issues when the MTU setting is incorrect/mismatched.

Did you enable Jumbo Frames on the NAS? If so try disabling it.

Maybe with a static IP you need to set the MTU manually, but with DHCP it is detecting and setting it automatically.

Also for your Network/DHCP config. Make sure you only have one of the 3 DHCP servers enabled (I would suggest use the one on the Netgear router).

  • First, I tried jumbo frames, but then I disabled them on all my devices (back to default). The netgear is the only active DHCP server on the network. – Mr. T. Oct 3 '15 at 11:37
2

I dont think a wiring issue as it copy, and always fail at the end.

Remove your antivirus to test out, as it look to me a scanning error

  • I did some further testing. It seems that the IP configuration of one of the devices wasn't correct. After putting them on DHCP, the transfers go well. However.. I'm not aware what setting I did wrong :-s – Mr. T. Sep 26 '15 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.