1

After the update of Azure File storage sept. 28/29 2015 I am no longer able to connect to my Azure File Storage, from my Azure Windows Server 2012R2 virtual machine.

I try to connect and map the File storage as network drives using the "net use" command.

cmdkey /add:<storage-account-name>.file.core.windows.net /user:<storage-account-name> /pass:<storage-account-key>
net use <drive-letter>: \\<storage-account-name>.file.core.windows.net\<share-name>

But i get the error message:

CMDKEY: Credential added successfully.
net : System error 2148073478 has occurred.
At C:\BackupScripts\Map networkdrives.ps1:5 char:1
+ net use Y: \\<storage-account-name>.file.core.windows.net\<share-name>
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (System error 2148073478 has occurred.:String) [], RemoteException
    + FullyQualifiedErrorId : NativeCommandError

However I am perfectly able to connect to the File storage using the exact same command from my on-premises Windows 10 machine.

I have already tried the 'Disable "Secure Negotiate" on the client' workaround described in https://support.microsoft.com/en-us/kb/2686098 But that didn't solve the problem.

0

I have resolved the problem by rebooting the machine, even though it wasn't nice to reboot the production environment, it solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.