1

I am trying to install Centos-7 on Ubuntu vivit in Virtual Box using Ansible. I get through a large amount of configuration and set up before it fails with the message below. I have searched for various error types but haven't seen one with mine so I figured I will come here. Can anyone tell me what the errors mean? I suspect it is a failure to install PHP dependencies but I don't why they are failing and how to correct this.

Thanks

PLAY [all] ******************************************************************** 

GATHERING FACTS *************************************************************** 
ok: [default]

TASK: [common | check if EPEL is installed] *********************************** 
failed: [default] => {"changed": false, "cmd": "/usr/bin/rpmquery epel-release", "delta": "0:00:00.036192", "end": "2015-09-30 19:40:02.697466", "rc": 1, "start": "2015-09-30 19:40:02.661274", "stdout_lines": ["package epel-release is not installed"]}
stdout: package epel-release is not installed
...ignoring

TASK: [common | install EPEL] ************************************************* 
changed: [default]

TASK: [common | clean yum metadata on first run] ****************************** 
changed: [default]

TASK: [common | upgrade all packages on first run] **************************** 
changed: [default]

TASK: [mariadb | MariaDB Install] ********************************************* 
changed: [default] => (item=mariadb-server)

TASK: [mariadb | MariaDB my.cnf] ********************************************** 
changed: [default]

TASK: [mariadb | Starting MariaDB] ******************************************** 
changed: [default]

TASK: [mariadb | Enabled MariaDB Service] ************************************* 
changed: [default]

TASK: [mariadb | Ensure DB user exists] *************************************** 
changed: [default]

TASK: [mariadb | Ensure DB exists] ******************************************** 
changed: [default]

TASK: [mariadb | Import ConnectDB] ******************************************** 
changed: [default]

TASK: [php | Install PHP Packages] ******************************************** 
failed: [default] => (item=php,php-devel,php-pecl-zendopcache,php-mbstring,php-xml,php-mysql,php-gd,php-pdo,php-drush-drush,php-json,libmcrypt-devel,libmcrypt,php-mcrypt) => {"failed": true, "item": "php,php-devel,php-pecl-zendopcache,php-mbstring,php-xml,php-mysql,php-gd,php-pdo,php-drush-drush,php-json,libmcrypt-devel,libmcrypt,php-mcrypt"}
msg: unsupported parameter for module: update_cache

FATAL: all hosts have already failed -- aborting

PLAY RECAP ******************************************************************** 
           to retry, use: --limit @/home/jcorbett/playbook.retry

default                    : ok=12   changed=10   unreachable=0    failed=1   

Ansible failed to complete successfully. Any error output should be
visible above. Please fix these errors and try again.
  • What is unclear about the error message? msg: unsupported parameter for module: update_cache – fukawi2 Oct 1 '15 at 1:44
  • It would really help if you could specify at least the task and module that is throwing the error. – Bruce Becker Nov 25 '18 at 9:27
0

Without see the playbook, I can only assume here. It seems like you are using a unsupported parameter as suggested here.

- name: Run yum upgrade
action: command yum upgrade

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.