1

I have a VM several layers away that I want to access remotely, but I can't get to it for some reason. I've tried several things to figure it out, and I wonder if I am missing something. I would like to RDP into the machine or access the web application running on port 80 on the VM.

Here's the setup...

  • VM in question: VMWare VM, Windows Server 2003, PeopleSoft
  • VMWare Host: Virtualbox VM, Xubuntu 15.04 basic installation
  • Physical Server: IBM x3455, Ubuntu Server 15.04
  • Laptop: Ubuntu Desktop 15.04

The reason for the complicated setup is that it is temporary. I want to be able to make some changes to the "VM in question" and then give it back to the person who gave it to me. I don't want to clutter up my "Physical Server" with VMware when I don't plan to use it on an on-going basis.

Basically, I want to connect to the "VM in question" from the "Laptop".

Here's what I have tried:

Network set to Bridged

"VMware Host" has a network adapter set to bind. I went to Machine Settings > Network > Adapter 1 and set the "Attached to" option to "Bridged Adapter".

"VM in question" also has the network adapter set to bind. I went to Virtual Machine > Virtual Machine Settings > Network Adapter and selected the Bridged radio button.

So, my machines are all on the same subnet/network. Here are the IP addresses:

  • VM in question: 192.168.x.103
  • VMWare Host: 192.168.x.105
  • Physical Server: 192.168.x.15
  • Laptop: 192.168.x.110

DNS

I don't think that DNS is a problem. On my laptop, when I try to ping the VM in question it gets the IP address correct:

$ ping VM
PING VM (192.168.x.103) 56(84) bytes of data.
^C
--- VM ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 2014ms

Ping

I tried pinging at the different levels to see where the network traffic was getting stopped.

  • On the "VM in question", I can ping it's own IP address.
  • On the "VMware Host", I can ping the "VM in question"
  • On the "Physical Server", I cannot ping the "VM in question"

Firewall

I think the Xubuntu firewall was turned on in the "VMware Host". I have that off now.

I checked with:

user@VMWareHost:~$ sudo ufw status verbose
[sudo] password for user: 
Status: inactive

I originally turned it off with:

sudo ufw disable

Question

Do you see anything I missed? Is there a way to get network access to that VM from my laptop?

2
  • Have you allowed access through the network firewall that this VM is behind?
    – joeqwerty
    Oct 2, 2015 at 21:32
  • I don't think there is a firewall that I know of involved. The "VMWare Host" is a VM sitting on the "Physical Server". I can't ping between from the server to the either VMs. Maybe it is a Xubuntu thing? Maybe the firewall in Xubuntu isn't really turned off even though it says it is. Oct 2, 2015 at 23:59

1 Answer 1

0

Maybe is a problem with the Network Adapter, I solved it by go to Edit option in VMWare, Virtual Network Editor and Restore Defaults.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .