Is there is a way to prevent postfix from sending them to the sender? My boss asked me to do so, so I'm not going to argue with him, just need to disable it.

I've tried to discard them in header_checks, by filtering "From: MAILER-DAEMON" field, but originally these mails were send "from=<>" and then it will be replaced to MAILER-DAEMON after mail passes header_checks. Any ideas will be appreciated


Found the answer here How to disable "sender non-delivery notification" in postfix? Even it was downvoted, but works for me

The answer:


bounce    unix  -       -       n       -       0       bounce

should be changed to:


bounce    unix  -       -       n       -       0       discard

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.