2

I've done incautiously

docker run -v /:/mnt:ro someimage

It has resulted with some docker (docker v1.7) daemon error. Since then I can only boot in permissive mode and got lot of selinux errors. Most noticeable one is concerning unable to start journal service.

I've tried to do the relabelling ie by fixfiles relabel but with no success. Since it happened on Fedora 21, I've also tried to do the upgrade to F22 (all in enforcing=0) but after the upgrade problem still exists. Now have no clue how to find the proper way of fixing this.

0

Did you check /etc/sysconfig/docker or /etc/defaults/docker files maybe they are not configured with selinux option. Or maybe you didn't install docker selinux package ?

1
  • I've just checked I have instelled docker-selinux. And actually I don't care that much now about particular docker issue but more about the host system gone unstable and works only in permissive mode. So my main concern now is to fix host system (ie just fix selinux to allow enforcing). I know to be careful with volumes and don't expect to trigger the cause again.
    – ciekawy
    Oct 5 '15 at 19:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.