0

On a fresh Ubuntu 14.04 virtual machine I've run the following commands:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install nginx

sudo service nginx start

In a browser, if I go to the VM's ip or domain the default nginx page is not shown, the page times out with ERR_CONNECTION_TIMED_OUT. [I'm able to ssh in with both the ip and domain to run the commands above].

Error logs at /var/log/nginx/error.log just show the starting and stopping of nginx.

What are the first steps for debugging from here? Or was there an obvious step missed...

[Update] netstat -plunk:

While nginx is running the following two lines are within the netstat -plunt results:

$ sudo netstat -plunt
...
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      12391/nginx
...
tcp6       0      0 :::80                   :::*                    LISTEN      12391/nginx
...

Looks like nginx is listening on port 80, so that doesn't seem to be the issue.

0

Although Nginx was listening on port 80, you have to set port 80 to be open to http connections in Azure.

  • See, you omitted a critical piece of information. If you'd mentioned in your initial question that you were using Azure, my first question back to you would have been to ensure that the Azure firewall had been configured correctly. – EEAA Oct 5 '15 at 16:39
  • @EEAA, Thanks for coming back to the question! In my defense I later added multiple updates in which I also mentioned it was deployed with Azure. I removed some of the details just to be on the slightly safer side not giving out IPs etc. Never said I knew all the information to give ;). – Shwaydogg Oct 5 '15 at 16:55
  • If this is solved, please mark it as solved by clicking the tick mark to the left, so that it turns green. – Michael Hampton Mar 23 '18 at 3:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.