1. vim /etc/group
2. Could not find "admin" group
3. adm:x:4:MYUSERNAME << added it here, because I assume this is "admin"
4. quit the vim editor...and tried it under my username...and it DOESNT WORK! 

The "adm" group is not the same as the "admin" group.

Also, you should never edit /etc/group by hand. If you mess something up, you can end up with a broken system.

The easiest command for adding someone to a group is like this:

gpasswd -a MYUSERNAME admin

If you're trying to give someone sudo-rights, can also just run visudo as root, and add a line like this to the file:


If you want to give sudo-rights to everyone in the "adm" group, you can do something like this

%adm ALL=(ALL) ALL
  • visudo, I ran that as root. bash: visudo: command not found – Alex Oct 8 '09 at 20:17
  • What version of Ubuntu is this? I haven't heard of any Ubuntu versions that didn't ship with sudo… If you don't have sudo installed, try running apt-get install sudo. – mikl Oct 8 '09 at 20:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.