0

System: 3.10.17-gentoo

NET-SNMP version: 5.7.3.pre5

ps ax: /usr/sbin/snmpd -p /var/run/snmpd.pid

/etc/conf.d/snmpd: #SNMPD_FLAGS="${SNMPD_FLAGS} -Lsd -Lf /dev/null"

/var/log/net-snmpd.log:

Connection from UDP: 
Connection from UDP:
Connection from UDP:

My net-snmpd log around 600 Mb If im trying to echo "" > /var/log/net-snmpd.log file becomes 0 Mb, and after a few minutes again 600

I found some manuals, but my config files has different content. How can i clear log file correctly or stop it?

1
0

You need to remove the "#" from that line in /etc/conf.d/snmpd, then restart snmpd. :) However, that will send output from snmpd to /dev/null, and use syslog for logging.

If you wish to disable all logging, or at least not have it sent somewhere you'd see it, something like this should suffice instead of that line you have:

SNMPD_FLAGS="${SNMPD_FLAGS} -Lf /dev/null" # note we've removed the syslog option

Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.