When i run:

mount -a

as root user in my virtualbox machine i will get the samba share mounted, so my settings in my /etc/fstab are working:

// /vagrant/Downloads cifs credentials=/root/.smbcredentials,auto 0 0

But why is this share not automounted when my virtualbox machine is booting? I run virtualbox in headless mode using vagrant. At the moment i need to run this sequence:

vagrant up
vagrant ssh
sudo su
mount -a

While this should be enough:

vagrant up

I am new to debian administration. Is there a log file for fstab / mount issues, that can be viewed after booting? Could it be a timeout or dependency issue on booting? How to debug it best?


2 Answers 2


The network might not yet be initialized at this point. You can add _netdev to the mount options. This will delay the mount until the network is connected.

// /vagrant/Downloads cifs credentials=/root/.smbcredentials,_netdev,auto 0 0
  • The root cause was a different issue. But pointing out _netdev makes sense, too. Thanks. You got an up-vote. Oct 8, 2015 at 13:26

The mount point target:




is itself not available at booting time. /vagrant is a mount point itself, which is introduced by vagrant tool right after the virtual machine boot finished.

Changing fstab to:

// /mnt/Downloads cifs credentials=/root/.smbcredentials,auto,_netdev 0 0

did the trick of mounting it at boot time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.