0

I work at a university and we have recently switched our email from an old system managed by the university to Office 365. Because the old system only allowed a very small amount of server space, I used a POP setup and kept all of my email locally. Now that I have tons of space I want to move it back to the cloud.

I set up an Exchange account in Office using the new Office 365 settings. All of my old mail and folders are now setup to be synchronized, and they are indeed synchronized, but only which I click on the folder in Outlook.

For example, I have open the Microsoft Exchange Connection Status window. When I click a folder in Outlook to view it's contents, the status windows shows that that folder is being synchronized. I can go to Office 365 on the web and verify that everything has pushed to the cloud. However, if I don't click a folder nothing happens. It seems to be only synchronizing when I click a folder in Outlook.

I have tons and tons of folders... so I really don't want to click them all. Surely there must be some way to force synchronization of everything? Or at least force synchronization of a folder and all its subfolders?

  • Do you use Outlook 2010 or 2013 to connect to Office365? How are the mail data is preserved? Is it in PST file on the workstation? – Vick Vega Oct 11 '15 at 2:19
  • 2010, local PST file – zeke Oct 12 '15 at 5:22
0

It's a bug, I would create a new outlook profile but you can also go into each folder's properties and change the Folder Synchronization Setting. It's happened to me a few times when importing lots of email via the client.

See terrible YouTube video, but as you said there are a lot so creating a new profile is easiest.

| improve this answer | |
0

I went into account settings and disabled "Cached Exchange Mode", restarted, reenabled "Cached Exchange Mode" and instantly everything started to sync again. So I don't know what was wrong, but that seems to have resolved matters. Gonna let it run overnight to see if everything gets synced as expected.

Update: it still stalls out every now and then and stops syncing. But if I restart Outlook it starts to sync again. So at this point I'm just restarting Outlook every now and then and hoping that eventually I get everything synced up.

| improve this answer | |
0

The simplest way is to create a new profile, then import the PST using Outlook to your mailbox. As alternative, import PST using powershell directly into the Office365 mailbox.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.