First off, I'm a programmer that needs to fix certain networking issue's so bear with me :). Also, sorry for the question title. I couldn't think of a better one.

Secondly, it's not the same as the question: Domain Controller thinks its on a Public Network, since that guy had IP v6 enabled and disabled that to solve his problem. Below I specifically state what my problem is and what I've found.

Our network has 2 domain controllers that are really active at the moment. We can't run the servers at night for the time being so we need to start them in the morning.

Things I've tried:

  • Everything stated here: Domain Controller thinks its on a Public Network
  • Appending a primary DNS suffix etc in the network adapter.
  • Managing the fixed IP address in our router.
  • Changing in 'Local Security Policy' so that all unidentified networks are private.

After starting out "primary" DC, it connects to a public network called 'Network 5', after I restart the network adapter it connects to a domain network called '.org'(it's called our domain, but I prefer to remain anonymous) and everything is working. After a while I came across this:

This network profile is under managed: The 'Network 5' profile, Which has a wrong MAC address.

This network profile is under unmanaged: The '.org' profile, Which has the correct MAC address

So, is this wrongly configured or is there something else going on?


I'm not following you as your question is a bit of a ramble.

That being said, there's no wizardry involved so stop making changes that you have no idea of the effect of.

You should not be manually assigning a connection-specific DNS suffix, so undo that change.

Don't manually try to set the network location, so undo that change.

Don't disable IPv6. If it is disabled then re-enable it.

The router has nothing to do with it.

As a first step to resolving this, make sure that you're following best practice regarding DNS client settings on Domain Controllers, which current best practice dictates as:

Each DC/DNS server should use a partner DC/DNS server for primary DNS. Each DC/DNS server should use itself for secondary DNS. Each DC/DNS server should use for tertiary DNS.

Here's what I've seen work in this type of scenario: When you start these servers in the morning start them one at a time. After the first DC is started and has been running for a few minutes start the second DC. After the second DC is started and has been running for a few minutes then restart the first DC.

The problem you're running into is likely because neither DC can initialize the network stack, DNS and AD DS from a simultaneous cold boot. Let one of them boot up and initialize, then the second one, then reboot the first one again. That's worked for me in this scenario.

  • Naturally, if the change didn't work I would reset it to how it was. So the network profiles are correctly set up and I just need to change my startup procedure? – OfficialBAMM Oct 12 '15 at 5:25

It sounds to me like you may have a second network adapter in your machine, (indicated by the wrong MAC address comment). I'd suggest either disabling the second NIC or teaming them together.

  • So it is possible to startup up 1 DC and automatically be put in the domain network? I would think so, but I'm no expert.. – OfficialBAMM Oct 13 '15 at 10:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.