1

vSphere client cant connect to ESXi 5.5. System error message:

Call "ServiceInstance.RetrieveContent" for object "ServiceInstance" on Server failed.

The request failed because the remote server took too long to respond. (The command has timed out as the remote server is taking too long to respond)

I dont change any settings in ESXi when this problem was spotted. I have tried to connect with different computers. Error message was same. When i trying to connect i see message of ssl cert, then client try to connect for long time, and finaly i get this error.

But i can ping server with ESXi. When i do telnet 443 i get black screen of cmd. All virtual machines running on hypervisor works, and i can acces to VMs with 443, 80, ssh and rdp.

Scan ESXi with nmap.

Not shown: 989 filtered ports

PORT     STATE  SERVICE

22/tcp   closed ssh

80/tcp   open   http

427/tcp  open   svrloc

443/tcp  open   https

902/tcp  open   iss-realsecure

5988/tcp closed wbem-http

5989/tcp open   wbem-https

8000/tcp open   http-alt

8080/tcp closed http-proxy

8100/tcp open   xprint-server

8300/tcp closed tmi

How can i fix this problem?

  • Can you connect to it from a device on the same segment/VLAN? Trying to see if it's a FW issue – Chopper3 Oct 9 '15 at 16:36
  • No i cant. I can reload host, but trying, that VMs will shutdown after it. And i can connect with KVM console. – mr_blond97 Oct 9 '15 at 17:22
  • 1
    What ESXi build number are you running? What type of storage is the hypervisor installed on? What type of storage are the virtual machines stored on? – ewwhite Oct 9 '15 at 17:28
  • Restart the VMware services or Restart the vCenter server. Your connection Problem would be resolved. – Manoj Nair Jun 20 '18 at 4:37
2

I fixed it this way:

DCUI:

  • Connect to the console of your ESXi host.
  • Press F2 to customize the system.
  • Log in as root.
  • Use the Up/Down arrows to navigate to Restart Management Agents.

Note: In ESXi 4.1 and ESXi 5.x, this option is available under Troubleshooting Options.

  • Press Enter.
  • Press F11 to restart the services.
  • When the service has been restarted, press Enter.
  • Press Esc to log out of the system.

From Local Console or SSH:

  • Log in to SSH or Local console as root.
  • Run these commands:

/etc/init.d/hostd restart /etc/init.d/vpxa restart

Note: In ESXi 4.x, run this command to restart the vpxa agent:

/etc/opt/init.d/vmware-vpxa restart
|improve this answer|||||
  • /etc/init.d/hostd restart was enough for me. – mwfearnley Sep 11 '17 at 9:41
0

I up the PDC Server first and so reboot the vcenter server and it works.

|improve this answer|||||
  • Welcome to the community, please complete your answer and come up with a more technical details so as other users can refer to your answer if accepted. By the way, I guess restarting servers is not something that System Administrators will like ;) Wish you luck, and success. – FarazX Mar 24 '17 at 18:34
0

I got same issue, and found that server network driver was mismatched, in my case HP emulex driver was causing the issue, so i have downloaded the same and updated it on esxi.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.