I have connected to my work's VPN network from my home PC without problem. Unfortunately, I can't seem to get much working beyond that.

For example, at work there's a computer named "Foo". If try to ping "Foo", the name resolves to the correct IP address, but I receive 100% packet loss. Any attempt at establishing a remote desktop connection also fails.

I've completely disabled my firewall at home in an attempt to resolve the problem with no success. My home PC is running Windows Server 2003, and my work PC running Windows XP Professional.

Do any VPN experts have any idea of what might be going on?

I would hazard that this is a routing problem. Either your machine doesn't know how to route to 'Foo' or 'Foo' doesn't know how to route back to your machine.

Checking this would take you looking at the routing table on your local machine by using 'route print' if you are on a windows machine.

The other side of the equation is to look at the routing table of your default router on the corporate network. It should know how to route your machine's VPN IP to the VPN access server.

I agree with Mitch. It's likely a routing problem.

In the command prompt, try "route print", and make sure that there's an entry for "Foo", and that the interface associated with "Foo" is the virtual network interface corresponding to the VPN.

Is there a firewall restricting what you can see at work?

Many companies will only allow access to certain services over VPN. Even ping may be blocked.

Depending on how your VPN is set up, it may only push out routing information for one or two subnets on the internal network.

If there is no firewall in place behind this, you may be able to set up the routing manually and get it to work, but the best option would be to configure the VPN to support the required subnet.

Expanding upon Mitch's answer, it may be a routing problem because your home networking subnet is the same as your office subnet. For example, if both networks are using 192.168.0.x, then your computer will have problems accessing network resources.

The solution would be to change your home networking setup, to something uncommon like 192.168.52.x.

  • Or have the VPN configured to NAT outside connections. You can have like networks on each side without issue. – sclarson May 12 '09 at 21:53

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.