0

I have a set of PPP interfaces on my Linux server. But on bouncing(ifdown; ifup) the interfaces which are not working, the PPP interfaces takes the lowest possible interface number.

If I have a PPP interface configured as ppp12, it will take a name like ppp5 if the ppp5 interface number is available at the point. Is there a way to track which is the exact interface name corresponding to it's configuration(/etc/sysconfig/network-scripts/ifcfg-ppp3)?

  • Did you try to put DEVICE="ppp3" in your /etc/sysconfig/network-scripts/ifcfg-ppp3 file ? – Iurii Vasylenko Oct 19 '15 at 7:19
  • @Yura Vasylenko I already have DEVICE="pppX" in the config file. – nitins Oct 19 '15 at 10:39
1
+50

I faced same problem at my Debian Wheezy and resoved in this way:

1) at file(for example) /etc/ppp/peers/pppDOMRU i've added new parameter ipparam pppDOMRU, and config begal look like

 hide-password
 lcp-echo-interval 20
 lcp-echo-failure 3
 connect /bin/true
 noauth
 noaccomp
 default-asyncmap
 plugin rp-pppoe.so eth1
 noipdefault
 nopersist
 maxfail 1
 user "some username"
 ipparam pppDOMRU

2) Then I modified /etc/ppp/ip-up. You can find modified script here

When interface is bringing up, this modified script renames interface according ipparam parameter like this:

pppDOMRU  Link encap:Point-to-Point Protocol  
          inet addr:XXX.XXX.XXX.XXX  P-t-P:XXX.XXX.XXX.XXX  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:2754927 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2644464 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:1114129844 (1.0 GiB)  TX bytes:296204844 (282.4 MiB)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.