2

I'm trying to setup a local instance of readthedocs for managing project documentation. I believe I've got everything installed properly with readthedocs and it's dependencies in its own virtualenv, following: http://read-the-docs.readthedocs.org/en/latest/install.html

manage.py runserver comes up without issue, so now I'm trying to set it up to be run with nginx+uwsgi.

Using Commandline from the '/var/www/rtd/checkouts/readthedocs.org' directory:

uwsgi --http :8111 --module readthedocs.wsgi --env DJANGO_SETTINGS_MODULE=readthedocs.settings -H /var/www/rtd

I get the error:

django.core.exceptions.ImproperlyConfigured: Error importing module privacy.backends.syncers.DoubleRemotePuller: "No module named privacy.backends.syncers"

I suspect this is some kind of path issue, and the library can't be found, since it runs with runserver.

Does anyone have an clues to what I'm missing here? Or, are there other recommended ways of running a local instance of readthedocs?

Referencing : http://uwsgi-docs.readthedocs.org/en/latest/tutorials/Django_and_nginx.html

0

I found that when using runserver, "readthedocs.settings.sqlite" was being set as the DJANGO_SETTINGS_MODULE. Updating the uwsgi line to match this resolved the privacy.backends.syncers.DoubleRemotePuller import issue

uwsgi --http :8111 --module readthedocs.wsgi --env DJANGO_SETTINGS_MODULE=readthedocs.settings -H /var/www/rtd

However, this still seems as if it will be a problem when running with postgres.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.