1

I have a problem with my PRTG monitoring system.
I need to monitor my server running VMware ESXi. My ESXi config :

esxcli system snmp set -c ...
esxcli system snmp set -p 161
esxcli system snmp set -t x.x.x.x@161/....

(sorry for x.x.x.x and ... is secret)

In prtg web I configure the same community string, port, type of snmp version. But when I add sensor VMware Virtual Machine (SOAP), it has a error : Error Message The session is not authenticated. So, how can I solve this problem? Thank for help!

0

This sensor is using SOAP and not SNMP, so your SNMP settings won't matter here. In PRTG you have to enter the ESXi credentials, not the SNMP community password.

Are you sure you meet all requirements for this sensor?

https://www.paessler.com/manuals/prtg/vmware_host_hardware_status_soap_sensor

Requires .NET 4.0 or higher to be installed on the probe system.

For this sensor type you must define credentials for VMware servers on the device you want to use the sensor on. Ensure you enter a user with sufficient access rights to obtain statistics (read-only usually works).

This sensor only shows items that report an actual status, so you might see more "sensors" in your vSphere client than the number of states available in the channels of this PRTG sensor.

The parent device must be a VMware ESX/ESXi server version 4.0, 5.0, 5.1, 5.5, or 6.0. We recommend that you do not use this sensor type on your vCenter. Reliable hardware information can only be provided when this sensor is created on your physical host server as parent device.

We recommend Windows 2012 R2 on the probe system for best performance of this sensor.

Note: This sensor type can have a high impact on the performance of your monitoring system. Please use it with care! We recommend that you use not more than 50 sensors of this sensor type on each probe.

| improve this answer | |
  • Yes, i tried it, but it still not, i use ESXi credentials login in ssh and vSphere, both it is successed. In my esxi host, i also open firewall for all connetion. I think something in esxi host prevent this authentication to add sensor. – Ha Phuoc Oct 15 '15 at 10:43
  • 1
    Try using domainname\username for the login name. Also attach some screenshots. Which version of ESXi? Which version of PRTG? – duenni Oct 15 '15 at 11:24
  • Version of prtg is 13.1 and esxi is 5.1. i used that credentials to login vcenter, it still sussced. I have 2 esxi host and same config. But in host A, i can add success, host B it don't. So ridiculous. – Ha Phuoc Oct 16 '15 at 1:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.