I had a record store.example.com which was set up as URL Redirect to foo.bar.com. 14 hours ago, I changed this record to a CNAME record to point to qux.bar.com.

Now, nslookup shows that the record has updated just fine. However, all of my devices still lead to the wrong website when I type in store.example.com in their browsers. I have already tried flushing DNS, restarting PC, changing DNS resolver. What am I missing?

  • It might not be a DNS issue but browser related instead and the following Q&A on Stack Overflow might be relevant stackoverflow.com/questions/9130422/…
    – HBruijn
    Oct 16, 2015 at 11:27
  • Hmm, I really thought you had me there, but the old URL redirect was a 302, not a 301. I've also tried clearing my browser cache and verified that it was empty, but still leads to the old address. Oct 16, 2015 at 12:50

1 Answer 1


I still don't exactly know what is causing this, but I changed the CNAME record to a URL redirect record, and now it works fine. I think it had something to do with CNAME chain.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.