0

Here is my /etc/vsftpd.conf in debian8:

anonymous_enable=YES
local_enable=YES
write_enable=YES
chroot_local_user=YES
local_root=/home/ftp
anon_root=/home/ftp 

I can connect the ftp server with open 192.168.1.100 (My local ip is 192.168.1.100).

Why can't connect the ftp server when to add two lines into /etc/vsftpd.conf?

anon_upload_enable=YES
anon_mkdir_enable=YES
  • What do your logs say? – womble Oct 17 '15 at 4:48
-1

1.anonymous_enable=YES---> To enable Anonymous users (No authentication).
2.local_enable=YES -----> To enable local users able to login
3.write_enable=YES ----> To make it writable
4.chroot_local_user=YES ----> To Change their Root directory
5.local_root=/home/ftp ---> Default directory for ftp users
6.anon_root=/home/ftp ---> This is root Directory for anonymous (un-authentiated users)
7.anon_upload_enable=YES --> To enable Anonymous users upload files
8.anon_mkdir_enable=YES -->To enable Anonymous users make directory

You should be configured your server either to be authenticated or un authenticated....cannot be both.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.