2

My server running Server 2003 R2 has been reporting multiple 12292 and 10 VSS errors when the UniTrends agent calls to the Shadow Volume Provider for a VSS Snapshot. The server has the latest updates including SP2.

Thus far I have: • Checked vss writers using the vssadmin list writers command : All writers were stable with no errors • Checked providers using the vssadmin list providers command: Only the Microsoft Software Shadow Copy Provider appears • Tried to access C:\ properties > Shadow Copies but the window froze. I rebooted the server and was able to access it. • Verified that the HKLM\SYSTEM\CurrentControlSet\Services\swprv parameter wasn't missing

Here is a copy of the events:

Event Type:         Error
Event Source:     VSS
Event Category: None
Event ID:              12292
Date:                    10/17/2015
Time:                    12:11:08 AM
User:                    N/A
Description:
Volume Shadow Copy Service error: Error creating the Shadow Copy Provider COM class with CLSID {65ee1dba-8ff4-4a58-ac1c-3470ee2f376a} [0x80080005].
Event Type:         Error
Event Source:     VSS
Event Category: None
Event ID:              10
Date:                    10/17/2015
Time:                    12:11:08 AM
User:                    N/A
Description:
Volume Shadow Copy Service information: The COM Server with CLSID {65ee1dba-8ff4-4a58-ac1c-3470ee2f376a} and name SW_PROV cannot be started. Most likely the CPU is under heavy load. [0x80080005]

The only other step I haven't tried was reregistering the VSS dlls. I am in the process of trying that. Do you recommend any other additional steps to diagnose and resolve the root issue? Thank you for your assistance.

2
  • I know you see error events in your logs, but are your backups actually failing? I ask because I've worked an issue extremely similar to this one with Unitrends support, and they essentially told me to just ignore it as long as my backups worked. – Ryan Ries Oct 17 '15 at 17:03
  • Hey Ryan, the backups for this one particular server are failing. I also have another server that receives these errors and backs up fine. Is it just the way that the agent interacts with the vss services? UniTrends just told me to search by the event and contact Microsoft if needed. Also an update I reregistered the vss dlls and was able to backup successfully. I'll review the backup jobs on that server for future events. Do you know of any other way to debug the issue? Thanks for the help. – EMFCo Oct 17 '15 at 18:57
1

Re-register the DLLs for VSS:

 cd /d C:\Windows\system32
 net stop vss
 net stop swprv
 regsvr32 /s ole32.dll
 regsvr32 /s oleaut32.dll
 regsvr32 /s vss_ps.dll
 vssvc /register
 regsvr32 /s /i swprv.dll
 regsvr32 /s /i eventcls.dll
 regsvr32 /s es.dll
 regsvr32 /s stdprov.dll
 regsvr32 /s vssui.dll
 regsvr32 /s msxml.dll
 regsvr32 /s msxml3.dll
 regsvr32 /s msxml4.dll
 vssvc /register
 net start swprv
 net start vss

Source: You answered your own question on the TechNet forums - just making sure the answer is updated here as well, in case you don't come back:

https://social.technet.microsoft.com/Forums/en-US/a1cb0922-6bce-4a5d-9d65-735b1ba5eef5/multiple-12292-and-10-errors-at-beginning-of-3rd-party-backup?forum=windowsbackup

0
0

Other ways to debug the problem from Veritas Article ID 000009160

Verify the Volume Shadow Copy and Microsoft Shadow Copy component services are set to either manual or automatic and can be started.

Open the DCOM configuration tool by running "DCOMCNFG" at a run prompt and verify Microsoft Shadow Copy Component is listed under DCOM Config, if not listed run the following to register the the necessary dll :

"regsvr32 /i%windir%system32swprv.dll"

Check on which Server the Snapshot Error is occurring from the Job Log. Then on the same server open Command Prompt and check the VSS Writers Status and Providers with the following commands:

vssadmin list writers - all writers should report "Stable - No Error"

vssadmin list providers - should report Microsoft VSS if no other Hardware Snapshot Provider is being used.

If the error is being generated on a Windows Server 2003/2003 R2 machine, please install Microsoft Patch KB 940349 after downloading it from the following link:

support.microsoft.com/kb/940349

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.