40

I'm trying to RDP into one of my servers, which as Network Level Authentication Enabled as well as NTLMv2 being forced. This worked fine until the server had to reboot for updates. Now, I cannot RDP into my server anymore. I get this error trying to connect via RDP:

An authentication error has occurred - The function requested is not supported enter image description here

This translates to: An authentication error has occurred. The function requested is not supported

I tried several things I found by googling, for example adding extra SecurityPackages values to the registry as described here: http://funeasytech.com/rdp-connection-error-of-the-requested-security-package-does-not-exist/ but that didn't work. Neither did changing the Group Policy on the client solve my issue, as described here: https://stackoverflow.com/questions/17371311/the-function-requested-is-not-supported-exception-when-using-smtpclient-in-azu

The problem is that I don't have physical access to this box, only via RDP. The server is running Windows Server 2012 R2 Standard, the client is running Windows 10 Pro.

How can I regain access to my server?

1:

6
  • Have the same problem, seems to be something client side, as I can connect from other computers. Client also on Win 10 Pro. Did you ever find the solution?
    – toster-cx
    Commented Nov 29, 2016 at 16:14
  • I have the same problem, client is a 2012R2 itself, can't connect to several Windows Servers anymore. Other clients work, so I blame it on the client not the remote server as well. Commented Mar 4, 2017 at 5:03
  • Details on the error should be in the Windows event log: Microsoft-Windows-TerminalServices-RDPClient/Operational Commented Mar 4, 2017 at 5:16
  • @toster-cx Sorry for the delayed reply, but no, I did not find a solution and ended up formatting the machine :(
    – Freek
    Commented Apr 26, 2017 at 7:00
  • @Freek any chance you used blackbird or similar software on the client machine? This solved it for me: serverfault.com/questions/818792
    – toster-cx
    Commented Apr 29, 2017 at 11:45

4 Answers 4

55

I had the same issue. I found the issue has to do with a Windows Update patch that was pushed out to my work station in last nights Windows Updates. There was a critical CVE (CVE-2018-0886) for RDP which required a patch to fix.

If your workstation is patched, but your server isn't, your workstation will fail to connect.

Quoting from the following blog website with information about the issue, you've got three options:

  • Patch your target computer for CVE-2018-0886 (Recommended)
  • Enforce the Vulnerable parameter on the source computer (Not recommended)
  • Disable NLA on your target computer (Not recommended)

I didn't have alternative access to the server(remote access only), so I had to chose Option 2 so I could go do the updates on the server.

I opened the start menu on my work station, searched for "group policy", clicked Edit Group Policy. Then following Microsoft spec, Go to "Computer Configuration -> Administrative Templates -> System -> Credentials Delegation", then :

  • Setting Encryption Oracle Remedation set to "Enabled"
  • In Options below, set "Protection Level: to Vulnerable
5
  • 1
    Thank you, man. I dig into this a hour already. Lowering security from System -> Advanced didn't worked. Microsoft should add a warning, or better message, instead of blocking access. P.S. Encryption Oracle Remedation is the key, which must to be enabled.
    – TPAKTOPA
    Commented May 10, 2018 at 8:15
  • Well, I have windows 10 Home and there is no Group Policy! Commented May 12, 2018 at 6:47
  • My Windows 10 machine had this problem after updating. Could not connect to a Windows Server 2016 box. Installed KB4103723 on the server, rebooted, and can now connect. Server 2012 r2 will need KB4103725.
    – root
    Commented May 14, 2018 at 19:15
  • Do you have to reboot your client after applying this GPO change?
    – RonJohn
    Commented May 18, 2018 at 15:01
  • @RonJohn No, I didn't have to reboot. Commented May 21, 2018 at 0:04
2

See Windows RDP: ‘An authentication error has occurred’

This is happening after you have a applied a windows security update it was this security update. It also tells you how to change your GPOs accordingly.

Don’t Simply Uninstall Windows updates KB41037272. and or KB4103718 – just because something works does not mean that’s what you should do!

2

I had the same issue with a remote VM, with only RDP access. This worked for me...

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\CredSSP\Parameters] "AllowEncryptionOracle"=dword:00000002

0

If your target server is Windows Server 2016, the first package from this list (2018-05 Cumulative Update for Windows Server 2016 for x64-based Systems (KB4103723)) worked for me:

  • Download and Install on target server
  • Restart

As already mentioned, this is the recommended way and does not require any other changes on source machines.

For Windows Server 2012 R2 the package 2018-05 Security Only Quality Update for Windows Server 2012 R2 for x64-based Systems (KB4103715) from here solved the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .