1

Hi I am new to linux environment.

Initially we had all the application working on a virtual machine. Due to some reasons we did not used it for a while. So after a long gap when we try to check that machine our tomcat was not running. There were progress in Tomcat7 after "Deploying web application directory". I also tried to install the tomcat server 7.0.35 and jre 1.7 again but no luck.

I will paste all the logs and steps taken to run apache server below:

[myName@nalnx123456789 ~]$ sudo /usr/local/sbin/tomcat
 --- Switching users ---
User Name     :  tomcat
UID           :  602
Home Dir      :  /usr/local/tomcat
[tomcat@nalnx123456789]~% ll
total 4
drwxrwxr-x 9 tomcat tomcat 4096 Oct 16 08:41 apache-tomcat-7.0.35
[tomcat@nalnx123456789]~% cd apache-tomcat-7.0.35

[tomcat@nalnx123456789]~/apache-tomcat-7.0.35% cd bin
[tomcat@nalnx123456789]~/apache-tomcat-7.0.35/bin% sh startup.sh
Using CATALINA_BASE:   /usr/local/tomcat/apache-tomcat-7.0.35
Using CATALINA_HOME:   /usr/local/tomcat/apache-tomcat-7.0.35
Using CATALINA_TMPDIR: /usr/local/tomcat/apache-tomcat-7.0.35/temp
Using JRE_HOME:        /usr
Using CLASSPATH:       /usr/local/tomcat/apache-tomcat-7.0.35/bin/bootstrap.jar:/usr/local/tomcat/apache-tomcat-7.0.35/bin/tomcat-juli.jar
[tomcat@nalnx123456789]~/apache-tomcat-7.0.35/bin% cd ..
[tomcat@nalnx123456789]~/apache-tomcat-7.0.35% cd logs

[tomcat@nalnx123456789]~/apache-tomcat-7.0.35/logs% ll
total 6
-rw-r--r-- 1 tomcat tomcat 1283 Oct 16 08:43 catalina.2015-10-16.log
-rw-r--r-- 1 tomcat tomcat 2556 Oct 19 01:23 catalina.out
-rw-r--r-- 1 tomcat tomcat    0 Oct 16 08:43 host-manager.2015-10-16.log
-rw-r--r-- 1 tomcat tomcat    0 Oct 16 08:43 localhost.2015-10-16.log
-rw-r--r-- 1 tomcat tomcat    0 Oct 16 08:43 localhost_access_log.2015-10-16.txt
-rw-r--r-- 1 tomcat tomcat    0 Oct 16 08:43 manager.2015-10-16.log

[tomcat@nalnx123456789]~/apache-tomcat-7.0.35/logs% cat catalina.out
Oct 16, 2015 8:43:02 AM org.apache.catalina.startup.ClassLoaderFactory validateFile
WARNING: Problem with directory [/usr/local/tomcat7/apache-tomcat-7.0.35_old1/lib/properties], exists: [false], isDirectory: [false], canRead: [false]
Oct 16, 2015 8:43:03 AM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/java/packages/lib/amd64:/usr/lib64:/lib64:/lib:/usr/lib
Oct 16, 2015 8:43:03 AM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["http-bio-8085"]
Oct 16, 2015 8:43:03 AM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["ajp-bio-8009"]
Oct 16, 2015 8:43:03 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 827 ms
Oct 16, 2015 8:43:03 AM org.apache.catalina.core.StandardService startInternal
INFO: Starting service Catalina
Oct 16, 2015 8:43:03 AM org.apache.catalina.core.StandardEngine startInternal
INFO: Starting Servlet Engine: Apache Tomcat/7.0.35
Oct 16, 2015 8:43:03 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory /usr/local/tomcat7/apache-tomcat-7.0.35_old1/webapps/manager


Java Version:
[tomcat@nalnx123456789]~/apache-tomcat-7.0.35/logs% java -version
java version "1.7.0_13"
Java(TM) SE Runtime Environment (build 1.7.0_13-b20)
Java HotSpot(TM) 64-Bit Server VM (build 23.7-b01, mixed mode)
[tomcat@nalnx123456789]~/apache-tomcat-7.0.35/logs%

Kindly help me to get me some clue to fix this issue.

Thanks in advance

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.