0

I tried to set up an CentOS7-Server with static IP-adresses and DNS-servers. The problem so far, is, that the Domain-Name-Service is not working properly.

TYPE=Ethernet
BOOTPROTO=static
IPADDR=***.***.***.49
NETMASK=255.255.255.240
NM_CONTROLLED=no
DEFROUTE=yes
PEERDNS=no
PEERROUTES=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
IPV6_FAILURE_FATAL=no
NAME=enp4s0f0
UUID=*******************************
DEVICE=enp4s0f0
ONBOOT=yes
DNS1=***.***.22.60
DNS2=***.***.56.60

The IP-address is created and the name-servers are "ping-able", but the DNS is not working. The resolv.conf automatically gets the following input:

DNS1=***.***.22.60
DNS2=***.***.56.60

Does someone have an idea how it comes to that problem.

(Its a clean CentOS7 installation with a GUI, nothing else has been installed or configured.)

thanks in advance

most sincerely

Twinhand

3
  • Do DNS lookups work if you query those servers directly? Try dig @***.***.22.60 serverfault.com to test this. (Using the actual IP address.) Does the DNS1=... part appear literally in your /etc/resolv.conf file? – Ladadadada Oct 19 '15 at 11:56
  • Thanks for the fast respond. So, if I do dig "at"..22.60, it finds something.Thanks for the fast respond. So, if I do dig "at"..22.60, it finds something. If I try to use dig "at"serverfault.com it get the following response "dig "at"serverfault.com dig: couldn't get address for 'serverfault.com': not found " And yes DNS1= is literally appearing in the resolv.conf – Twinhand Oct 19 '15 at 12:04
  • OK, it seems like I found my problem. if I delete the option "PEERDNS=yes". The system is writing the name-servers correctly (nameserver ..***.***) to the resolv.conf and the DNS is working properly. Thanks for your help. – Twinhand Oct 19 '15 at 13:11
0

OK, it seems like I found my problem. if I delete the option "PEERDNS=yes". The system is writing the name-servers correctly (nameserver ...) to the resolv.conf and the DNS is working properly. Thanks for your help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.