0

I have a file server running Windows Server 2008 R2 with 2 NICs in the back. These are their configurations:

Connection #1
Local Area Connection
10.1.37.6
255.255.255.0
[No Gateway]

Connection #2
Local Area Connection 2
10.1.35.49
255.255.255.0
10.1.35.254

At the moment I have connection #2 hooked up and working just fine. I have just created connection #1 in an attempt to connect to a private switch for iSCSI traffic.

Issue

When I plug in the ethernet cable into connection #1, some services related to connection #2 are turned off. Specifically, we can not log in using Remote Desktop and all of our printers (hosted on this file server as well) can no longer connect to fileserver1 to authenticate logins. However connection #2 is still pingable and the actual files stored on this server are still accessible to everyone. This issue reverts when connection #1 is unplugged.

Solutions Attempted

  • Changed network adapter's advanced settings "Adapters and Bindings" to prioritize traffic to connection #2
  • Changed NIC metric on connection #2 to be lower than connection #1
  • Removed gateway from connection #1 since that connection is only communicating with things on the 10.1.37.0 net
  • Checked file server routing table to confirm proper routes
  • Attempted to enable connection #1 as the iSCSI initiator adapter, hoping that once it was marked as being used for iSCSI, no other traffic would attempt to pass through it.

My understanding of this scenario is that once connection #1 is plugged in, it's attempting to direct traffic through that adapter instead of connection #2. I've done everything I think I'd need to to set up the priorities adapters.

Appreciate the help

0

Have you checked the below . . . Just a thought for something to check. I'm not certain about not having a GW on the second NIC though.

Source from below: https://social.technet.microsoft.com/forums/windowsserver/en-US/58e53691-64cd-44b9-98a2-ff1697e3ea83/unidentified-network-default-gateway

CHANGING UNIDENTIFIED NETWORKS (Windows Firewall Rules Applied)

  1. Start --> run --> MMC --> press enter
  2. In MMC console , from menu file select Add/Remove Snap-in
  3. Select Group Policy Object editor --> Press Add --> select Local computer --> press OK -->press OK
  4. Open Computer configration -->Windows Settings -->Security Settings -->select Network list manger policies

on the right Side you will see options for :

double click -->Unidentified networks

then you can select the option to consider the Unidentified networks as private and if user can change the location.

I hope that is will help you and is clear .

the good News that this have changed in windows 7 and Windows 2008 R2 , where user can change the connection type from an easy interface

enter image description here

Other Resources:

2
  • The server is actually running Windows 2008 R2. Just to confirm, what will this do exactly? I don't see this change making any traffic be redirected properly. I appreciate the help. – user3485484 Oct 20 '15 at 18:03
  • 1
    You know I didn't try this answer because to me it didn't make sense to why it would work. At the end of the line, I tried it and success. The printers are no longer going down when enabling the other NIC. Strange how an unidentified network ended up confusing the traffic. Thanks for your help. Also I found a place to control which NIC Remote Desktop uses for anyone who needs it: Start Menu - Terminal Service Configuration – user3485484 Oct 26 '15 at 19:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.