13

I am running ubuntu 14 on one of my servers.

When I run sudo apt-get update, I get the error below.

W: GPG error: http://cran.rstudio.com trusty/ Release: The following signatures were invalid: KEYEXPIRED 1445181253 KEYEXPIRED 1445181253 KEYEXPIRED 1445181253

Should I modify my ppa repository list or take some other action to fix this issue.

Update: I tried removing R from the server using

sudo apt-get --purge remove r-base
sudo apt-get --purge remove r-base-core
sudo apt-get --purge remove r-base-recommended

However, I am still seeing the same issue with apt-get update.

  • fixed after removing reference from /etc/apt/sources.list file – ali haider Oct 20 '15 at 17:06
  • I would recommend removing the paragraph about java, since the main issue is how to fix the broken key from RStudio. – user2161065 Nov 23 '15 at 19:17
29

Look at the "Secure APT" part of https://cran.r-project.org/bin/linux/ubuntu/README.html:

Adding the key with key ID E084DAB9 fixed the problem for me.

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys E084DAB9
| improve this answer | |
  • 3
    Part of the issue is the previous Key expired and had to be renewed. If you installed before mid October you might hit this issue. stat.ethz.ch/pipermail/r-sig-debian/2015-October/002458.html – wildintellect Nov 19 '15 at 17:43
  • I think this should be marked as the correct answer. – gawbul May 14 '16 at 9:25
  • If you are using Ubuntu's "Software & Updates" GUI tool (or whatever it's called in other distros), check the "Authentication" tab, which lists all keys known to dpkg/apt. This E084DAB9 key belongs to "Michael Rutter, marutterATgmail.com". It is the correct GPG key. Do not search for a CRAN substring in the list. – knb Jan 25 '17 at 9:34
4

If you don't need R you can just remove the cran line from /etc/apt/sources.list and you should be good to go.

sudo apt-key del 1445181253 will remove the offending key.

| improve this answer | |
  • solved by removing reference from /etc/apt/source.list file - thanks – ali haider Oct 20 '15 at 17:07
  • my java installation is still messed up - will look into it next – ali haider Oct 20 '15 at 17:07
  • Might take a look at this:digitalocean.com/community/tutorials/… – Eddie Dunn Oct 20 '15 at 17:09
  • Not sure which one you were using but you can install either Oracle or OpenJdk (whichever one you did not have before) and use update-alternatives like it describes at the bottom. – Eddie Dunn Oct 20 '15 at 17:10
1

Sorry for the abrupt questions but what has java to do with the 3rd party repository that you have set in your repository?

Also I see you are capable to change your repository but not able to read the output of an error.

You can add the missing key for the 3rd party repo:

  http://ubuntuforums.org/showthread.php?t=2202787
| improve this answer | |
1

In case your firewall blocks port 11371, a more general solution is to force using port 80 when retrieving the new key:

gpg --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys E084DAB9
gpg -a --export E084DAB9 | sudo apt-key add -
| improve this answer | |
0

fixed after removing reference from /etc/apt/sources.list file

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.