2

I have a licencing problem on Win server 2012 R2. I want to activate windows server 2012 R2 Datacenter using MAK(which I have) with standard procedure(my computer->properties->activate windows->enter activation key).

When I type activation key, always get message: "The key didn't work, please check it and try again, or try different key." I'm using proxy server, which is set by GPO. I have internet access, can normally open web pages.

I installed wireshark to check the traffic toward proxy server and made a capture, but it didn't show any traffic going towards proxy. Is there any way to "force" windows activation utility to connect on my proxy server, couse obviously it doesn't.

tryed different versions of "slmgr" command. Server is Dell Poweredge R930.

Anyone has any idea what to do?

Thanks in advance

2

You can bang your head against the wall trying to activate this over the internet ooooooor just go ahead and activate it over the phone.

  1. Open an elevated command prompt
  2. Type the following command: slmgr.vbs /ipk XXXXX-XXXXX-XXXXX-XXXXX-XXXXX
  3. Type the following command: slui.exe 4
  4. Call the toll free number
  5. Follow the automated instructions over the phone

I know this doesn't solve the mystery of why it won't activate over the internet, but hopefully this will get you going if you're in a bind.

  • Yep, this is the way to do it. 99% of the time the activation will be completely automated. If there is a problem with your key (like too many activations), you'll get transferred to a person who can fix it. – Grant Mar 29 '16 at 16:26
0

On Windows Server 2012 internet activation uses the winhttp proxy rather than the IE proxy, so setting your proxy via GPO won't work.

Open an elevated cmd and do the following:

netsh winhttp import proxy source=ie

Alternatively:

netsh winhttp set proxy 10.0.0.1:8080 "<local>"

Where "10.0.0.1:8080" is the IP address and port of your proxy server.

Then try to activate.

Some things may break following this; for example I have seen Exchange 2010 Management Console fail. To reset the winhttp proxy to use direct access do:

netsh winhttp reset proxy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.