0

I have installed a new ethernet cable and for some reason it works just fine when connecting a laptop to it, but when plugging it into the switch at that end, no connection is established.

Tried with multiple switches and multiple laptops, but each time with the same result. The switches refuse to acknowledge that there is something at the other end of the cable.

Tried various Netgear switches and a Cisco SMB300 8 port with ecomode disable and enabled. All switches are 1Gbit.

The cable is the Ubiquity Level 2 Carrier with shielding. Benn using it all over the place and never had any problems. The length of this run is approx 88 meters.

I wish I had some tools to show noise in the cable, but sadly that is beyond my budget.

As a side note, the new cable was installed after an old unshielded cable started acting up. The connection drops out a couple of times in a 24 hour period and the comes back after an interval ranging from 5 minutes to 3 hours. I gave trying to diagnose that and just ran a new length of cable, but now I have problems with that as well.

EDIT:More details I changed the switch up stream from the Cisco to a small Netgear 8port Gigabit desktop switch and it was able to establish a link with the Cisco.

But they only establish a 10Mbit link. I have tried disabling all the energy saving features on the Cisco, but with no change. I also tried setting the link speed manually which caused it to drop the link.

The Cisco switch has the capability to do a Copper Test, but for this particular cable it just grays out the button and write N/A on all the result fields. Neither is it able to tell me how long the cable is.

The funny thing is that is has established a link to another switch down stream over a 80 meter unshielded cable that is operating at full 1000Mbit.

I am running out of ideas.

  • Is cable straight or crossover? It can be problem with MDI/MDI-X setting in cisco (laptop - switch needs straight cable, switch - switch needs crossover, if you don't have auto MDI/MDI-X feature enabled.). Can it detect link up (ie. activity LED is lighting) or it looks like there is nothing connected at all? – Ondra Sniper Flidr Oct 22 '15 at 11:11
  • Cable is straight. Didn't check Cisco settings, but the Netgear switches are autosense. No link up is detected on any switch I try to connect. – Mathias Nielsen Oct 22 '15 at 11:47
  • Wonder if it's an auto-negotiate speed duplex mismatch issue with the port in the switch on the other side? I assume the 88 meter cable it terminating at a patch panel on one end that's then patched to a switch and then to a wall port on the other side which you are then connecting to a laptop or another switch? Or is this just a straight cable going from switch uplink to another switch uplink to expand the data network? The laptop NIC may be able to auto-negotiate the duplex and speed where the other switches cannot? Are the switches all managed switches where you've checked duplex & speed? – Pimp Juice IT Oct 22 '15 at 12:42
  • Its a straight cable between two switches. The switches at the live end of cable are not managed, but it shows the speed negotiated to 1000Mbits when a laptop is connected. I have not tried changing the switch at the live end (it's a 24 port Gigabit Netgear unmanaged), but it's completely new so I just didn't assume it would be a problem. – Mathias Nielsen Oct 22 '15 at 12:47
  • To troubleshoot the cable to ensure it's not the issue or some noise/interference between, you may want to connect something different to the live end with the other side just to be thorough. It may be worth getting a line analyzer on there to ensure no issues with the cable. It seems like a port speed duplex/mismatch issue or something though, but with unmanaged switches on both ends you cannot hard-code the speed and duplex so just use something different at both ends to troubleshoot to see what seems consistent with this regard. – Pimp Juice IT Oct 22 '15 at 12:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.