11

I know there are a couple of questions about this, those are different situations though and the provided answers do not relate to my problem.

I have a WD My Cloud EX2 NAS with a configured public share, I can access this share from my windows 10 laptop, windows 10 desktop and android phone without issues or authentication.

However, I did a clean windows 10 install of another desktop and the exact same share keeps asking me for authentication now and wont accept any input I give it.

I tried enabling a certain key in the registry (can't remember the key-name) and rebooting, but that didn't help.

Am I missing something? I'm 100% certain the share is still configured properly since I can still access it from my other machines.

EDIT 1: Something I just realized: the other windows 10 machines are Windows 10 Pro, this system is Windows 10 Home, not sure how that would affect this problem, but that's the only difference I can think of.

EDIT 2: I upgraded to Windows 10 Pro and still can't access the public share.

EDIT 3: When I enter \ as the username and leave the password blank it shows me the share contents, however when I reboot the computer it asks me for credentials again, it won't remember them.

EDIT 4: I have Plex installed on the server, when I get the authentication dialog for the samba share it shows the plex server name in the "domain" field. perhaps this influences the authentication protocol?

  • What's your "network location" configured as? Home/Work/Public? – Jacob Evans Oct 31 '15 at 21:37
  • it's not a network location, it's a mapped network drive. any other global network settings seem to be set to private network – xorinzor Oct 31 '15 at 21:43
  • Not what I asked, tenforums.com/tutorials/… – Jacob Evans Oct 31 '15 at 21:44
  • as mentioned that's configured to private network – xorinzor Oct 31 '15 at 21:57
  • This sounds really strange it seems like the NAS is requesting authorization in the form of login for this one machine this would normally say it's a miss configuration on the NAS, do you enable access to each Machine on the NAS or is it supposed to allow everyone on your network access it? – Martin Barker Nov 2 '15 at 16:58
3

I don't know how, but when I inserted as username \ and left the password field blank suddenly it accepted the credentials and showed me the share contents.

Maybe it will help someone else who has the same issue.

EDIT: when I originally posted this answer I couldn't check the checkbox to remember the credentials, causing me to have to do this on every boot. However, this time it did allow me to check the checkbox, I don't know what changed, but it's working now. might have been a windows update.

Another Edit: Upon every boot I now have to use smbpasswd to re-configure the correct password for the account.

Final Edit: It seems this question is getting a lot of attention, I think I should add that after all this time, I managed to solve the issue.

This is related to 2 possible reasons:

  1. A complete factory-reset
  2. leaving the username as "admin", I can't recall exactly what or why, but changing it to my custom username resulted in issues, whereas leaving it as "admin" worked perfectly fine. Possibly something hardcoded in the NAS firmware.
1

Some Items and Resources that may be related

Be sure to check out the above article too regarding a change with Windows 10 and registry key entry, etc. that's related to remote shared folders or network locations on a file server or NAS through CIFS, SMB or Samba protocol.

This talks about turning on allowing insecure guest but also talks about the Windows Credentials options as well.

  • Also, check for a saved credential to remove (or add perhaps) by typing in control keymgr.dll or maybe rundll32 keymgr.dll,KRShowKeyMgr from the RUN and then press enter. Remove (or add perhaps) the stored credentails that shouldn't be there and then see if it works as expected.

Lastly, I'm not sure if when you upgraded if it changed back that registry entry you changed, but it's important to remember what you change and backup before you change in case it doesn't work so you can revert that change back.

I wouldn't get into the habit of trying things and then before you know it you change 10 things so now you're not sure if any of those helped any or made the issue worse so jus think about this moving forward with these types of strategies.

EDIT1: I added a second link URL above that gives some pointers on this leading it to be either a Windows issue or a NAS configuration issue. On my Windows machine, I setup a share and granted ANONYMOUS LOGON both SHARE and NTFS anf then from another Windows machine I mapped a drive to it with \\PCName\ShareName and saved that without specifying a username or a password just fine.

  • 1
    The key named in that article (AllowInsecureGuestAuth) was indeed the key I meant, I'll re-check the key when I'm back home – xorinzor Nov 5 '15 at 22:51
  • the key was still set to 1, and win+r \\servername\sharename (obviously with the correct values) asked me for authentication again and would not accept empty values – xorinzor Nov 7 '15 at 17:17
  • please read my Edit #4 in the question, this might provide a clue as to what is going on – xorinzor Nov 7 '15 at 17:19
  • I tried that, but it promted me with a new authentication window for the actual server – xorinzor Nov 7 '15 at 17:44
0

I had an issue like this a long time ago. From memory, it was because the client had a set of credentials stored for that particular share that were wrong. It tried to use these wrong credentials each time it tried to connect, and when they didn't work it would ask the user for the correct ones (which was blank, because it was an open share).

If you type net use you will see a list of all the conections to SMB shares that the client is using, and you can use /delete to remove one. Full docs here on technet.

More information in this thread

It's a long shot, but I hope it helps.

  • I already tried this a long time ago, unfortunately that's not helping – xorinzor Nov 5 '15 at 22:50
  • please read my Edit #4 in the question, this might provide a clue as to what is going on – xorinzor Nov 7 '15 at 17:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.